[PLUGIN] Magicam for C2(Alpha 6.5 1/8/14)

  • farnsu - No problem, man; I'm glad it helped you out. What issues are you having, specifically, with restart layout? I might be able to help you out on that one.

    When it comes to camera paths, that's a feature I've considered before, but the complexity of such a thing is potentially high, depending on the implementation. It would likely require a system where you load in an XML file containing a series of camera moves. So, it's something I'll look into some more, but I can't promise anything.

  • New release, just a single bug fix.

    Alpha 6.3 release notes:

    Download Magicam Alpha 6.3 for Construct 2 (Includes example)

    <font color="red">(FIX)</font> Made attempt to fix crash when saving/loading the game with global cameras.

  • linkman2004

    Is there a way to limit the Zoom to contain? Something like a min/max zoom? Right now, with parallax/layer scaling turned on, it's going past what should be the "edges" of the level when zooming, going to the edge of the largest layer.

    It'd also be great if there were some way to set a minimum zoom, so that when, for example, two players are near each other the screen isn't zoomed in so far that they can't see the playfield around them.

  • digitalsoapbox - That should be fairly easy to implement, so I'll see what I can do. However, I'm incredibly busy right now, so no estimates on when I'll have an update out.

  • digitalsoapbox - That should be fairly easy to implement, so I'll see what I can do. However, I'm incredibly busy right now, so no estimates on when I'll have an update out.

    Awesome! I've tried limiting it myself when the zoom gets above/below a specific zoom level using MagiCam.GetZoom and stopping it from cross those thresholds, but I end up with a strange scaling flutter near those ranges.

  • linkman2004

    PM'd you about this, I might have some budget to push development along.

  • Amazing plugin, not sure if i've ever thanked you man, but THANK YOU. :) I've run into an issue that i am probably just braindead on solving, but when i setup a local camera to follow a local object, then that object is destroyed, i spawn a new instance (player) and the camera doesnt get back to following the new instance. I tried transitioning the camera to the new players position, which works, but the camera just doesnt follow him anymore.

    I am thinking its because it's still trying to follow the *now dead* version of the Player.. but what can I do to get it to start following the new one, i tried setting the camera follow upon respawning the new player, but i get no results....

    Any help would be massively appreciated! Thank you in advance.

    <img src="http://www.80bit.com/pic/Windows_7-20131129-114928.jpg" border="0" />

  • 80bit - The method as described in the picture should work, so I think there may actually be a problems with my plugin in this regard. I'll be busy up through the 13th of December, so I probably won't be able to fix it until then, but I'll try and get it done.

  • No problem at all, thank you so so much for having a look!!! I'll rely on "scroll to" while I'm building / testing and can always implement magicam later, so no rush at all!

    If there is anything I can do / anything I can provide to assist you please let me know and I'd be happy to!

    tx again. :)

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • As requested by digitalsoapbox I have added the ability to bound zooming when using zoom to contain.

    Alpha 6.4 release notes:

    Download Magicam Alpha 6.4 for Construct 2 (Includes example)

    <font color="green">(ADD)</font> Added zoom bounding for zoom to contain feature. Individual upper and lower bounds can be specified, with -1 in either field indicating no limit. NOTE: When bounding zooming, margins can no longer be guaranteed.

    Per usual, have fun, and be sure to let me know if you guys find any bugs.

    80bit - Don't worry, I haven't forgotten about the bug you found. Finals are over now, so I'll be able to look into it within the next day.

  • Pretty awesome, and working flawlessly! Thanks linkman2004!

  • digitalsoapbox - I'm glad it's working as you wanted. Be sure to let me know if there's anything else you'd like to see/need fixed.

    80bit - I figured out what was going on with your code! By design, whenever you initiate a camera transition - a movement transition, specifically - following is disabled. To fix your issue, you can use the On transition finished condition to check if your transition is finished, then use the Enable following action to re-enable following.

    I figured designing it this way would help reduce headaches where you transition to a point, but then it immediately goes back to following objects upon completion.

    I hope this helps!

  • Amazing, thanks for the feedback Linkman!!

  • Hi, been using an old version of Magicam for a while and noticed a later feature I would love to get in my game but when I update to anything past alpha 3 I get this error when trying to start my project.

    Action ID does not appear to exist in related plugin

    Condition: plugin->HasActionID(act_id)

    File: Projects\EventAction.cpp

    Line: 43

    Function: __cdecl EventAction::EventAction(class EventBlock &,class ObjectClass *,class BehaviorType *,int,class std::vector<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> >,class std::allocator<class std::unique_ptr<class EventParameter,struct std::default_delete<class EventParameter> > > > &&,unsigned __int64)

    Build: release 156 (64-bit) checked

    Component: Construct 2 IDE

    (Last Win32 error: 0)

    Not sure if that means anything.

    Have any idea to what the problem might be? my other projects work fine.

  • mapmerry - You wouldn't happen to be using the Un-follow object action, would you? It was added in alpha 3 and appears to have gone inexplicably missing in all versions after that. I'll get an updated version up as soon as possible with this added back in, but in the mean time, I'd check to see if you're using that action in your project, as it's the likely culprit.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)