[PLUGIN] Clay.io (leaderboards & achievements)

  • Just to add to the confusion... I moved the Post Leaderboard score to when the game ends to get the score. I don't get the error anymore, but now an "Enable Clay.io" dialog appears with three tabs Login, Guest and Signup but no way to enter anything. I added a button to Show the leaderboard scores, but when I press it a "Loading Leaderboard..." dialog appears and the revolving blocks just keep moving. I logged into my Clay.io account but when I view my leaderboard scores. I get a "No high scores yet".

  • Yes smiliar here...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Was this all working before the most recent version of the plugin?

  • I was finishing my game and same thing happened here.. if I try to preview it I get the clay_plugin.js error, but it disappears if I put the game online. I only made one game with clay.io before this one and it has been a while so I can't remember if it did work in the preview..

    Also, even so, when I start the game I ask the player to login but it's impossible. If I put my username/password the modal goes away but as soon as I try to award the player anything, it comes back and won't let me log in.

  • Wasn't able to replicate, but just in case, I repackaged and reuploaded the plugin files here: clay.io/docs/construct2

    If the same issues persist, my question remains for Raiper341 and neverquit on whether or not a recent plugin update started causing the issues. Thanks :)

  • Hah it is difficult... i used older version of clay.io plugin for 2 my games (Submarine escape and Catch birds birdman).Some days ago, i started to work on another third game and i wanted to use clay.io plugin again, but it did not work, when i wanted to show highscore, it did not work.. so i thought, that i need newer plugin, so i downloaded latest one. But then i had got same bug and some others more...

  • austin thanks, I think that actually did the trick!

    Edit: Nevermind, now it doesn't work anymore ):

    <img src="http://i.imgur.com/yVvxtda.png" border="0" />

    Really weird! I installed the new plugin, ran C2, tested the game and everything worked. Then I restarted it and now this!

  • Quick question.

    I'm thinking of making something that is more like an app than a game.

    Basically its an online list of snippets that clayio members can add to.

    I've already made something similar in CC with Gamejolts api.

    gamejolt.com/games/other/codestruct/5391

    Works nice, but an online version would be better, and dealing with the Gamejolt api is a bit tedious without a regular plug.

    So the question is:

    Do you have any problems with that?

    It is somewhat game related.

  • Are you guys making sure the Clay.io ready event has fired before calling the events? As an example, if you want to have some sort of Clay.io action right when the game loads - and the Clay.io API may not have fully loaded in - you have to use the Clay.io ready condition like so: grab.by/pOTM

    newt that's perfectly fine.

  • Ok thanks, I'll put it under educational.

  • I am sure... I mad test, only with clayio plugin. I add API key and in event sheet on start of layout -> show leaderboard and run and i see only this and browser freezes.

    <img src="https://dl.dropboxusercontent.com/u/21297365/obrazky/clayio%20problem.png" border="0" />

  • I'm maybe missing something.

    Is there no way to add a global save?

    For example to let the play add to the list of existing snippets.

    A list all players can view.

    Something similar to fetch user data, and store user data, but data for the app itself.

  • Raiper341 - try waiting for the "Clay.io Ready" condition to be met before calling that.

    newt - not currently, but hopefully soon :) (next 2-3 months)

  • Austin, I have the leader boards working now, thanks.

    I deleted and downloaded your repackaged plugin. I added the Clay.io Ready event, but when I ran my app, the leader board still stayed in a loading state. On a whim, I removed the API key thinking if I got the same results, maybe there was something wrong with my setup on the Clay.io website.

    When I ran the app the leader board loaded! I added the API key back and the leader boards still loaded. I saved the app and exited out of Construct2. When I got back in, and launched the app, the leader board still functioned. I was able to post scores and display them.

    I'm not sure what the actual problem was. I hope this helps someone else out.

  • Hi austin

    Clay.io plugin: 0.4.12

    Construct 2: 143

    Cocoonjs launcher 1.4

    Test device: Iphone 4gs

    I'm having two issues:

    • When I have logged in and have Clearence == 'clay', the Clayio.PlayerUsername is always 'Anonymous'.
    • When I prompt the logout dialog the dialog shows, BUT the 'Log me out' button never shows.

    As a result all users that posts a highscore are called Anonymous in the highscore list. But the list still shows the write picture and if I click a highscore I come to that user in clay.

    There are no error in the cocoonjs log.

    When testing this in a browser everything looks good.

    Screen shots from cocoonjs launcher:

    <img src="http://www.onemuppet.se/Games/Bugs/image.png" border="0" />

    <img src="http://www.onemuppet.se/Games/Bugs/image%20%281%29.png" border="0" />

    <img src="http://www.onemuppet.se/Games/Bugs/image%20%282%29.png" border="0" />

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)