Motion blur demo

This forum is currently in read-only mode.
  • Here's a demo of the motion blur. You can press:

    1 - Turn off motion blur for comparison

    2 - Default (5x) motion blur

    3 - 20x motion blur (ridiculously high, puts your graphics card through its paces!)

    Look round with the mouse and left click to shoot, arrow keys to move, featuring a cool zooming camera. Notice you can't see behind you if you look as far as you can one way!

    Could do with some more comments but hey...

  • That's awesome. It's very cinematic in a way. Like the camera's all shaky and zooming around frantically to try to keep up with the action.

    It looks pretty decent on my crappy card (the 5x blur does, anyway), but I can tell that the 100 fps it shows in the title bar is not accurate at all. Especially on 20x blur. On 20x blur it says 100-110 fps, but it's more like 4 fps.

  • The framerate is the temporal-antialiased framerate, which means the V-sync rate is 1/5th the framerate for 5x motion blur, and 1/20th for 20x motion blur. So yes, 100fps at 20x motion blur is actually 5 FPS V-Sync rate. Interestingly, low framerates are much more tolerable with motion blur on, because you're not seeing a series of slides - you can see the motion too.

  • That looks awesome Ashley .

    ---

    I have noticed something with the blur, and I feel this post is probably the best place to mention it while I can.

    Using 'every X ticks', 'Always', and for some reason only on 5x blur 'every X milliseconds', the increase in frames also increases the occurrence of the event.

    http://www.fileshack.us/get_file.php?id ... urtest.cap

    1 is Motion Blur off, 2 is x5, and 3 is x20.

    The 'every 1 ticks' and 'Always' make enough sense for me, but take note of the 'every 5 Milliseconds' box.

    Motion Blur off and x20 move at the same speed, but x5 moves about twice as fast as that.

    EDIT: It could just be my video card, I'm not sure.

  • EDIT: It could just be my video card, I'm not sure.

    Does it here too, on both an onboard (laptop) and an GeForce 8800GTX (desktop).

  • I see... I'll have a look and see if I can sort that out.

    Edit: fixed for next build.

  • Motion Blur off and x20 move at the same speed, but x5 moves about twice as fast as that.

    x20 is actually super fast here, so maybe it was just your loss of frame rate (is that possible with boxes) that made it the same as zero? Though I guess if Ashley's already fixed it this is irrelevant.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It probably would have varied from computer to computer. The timer was simply inaccurate over the motion-blurred frames. Should be back to normal for next build.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)