Walls!

This forum is currently in read-only mode.
  • Well, hello there

    I started using Construct just one day ago and I've gotten very far with a 2d shooter! but, I've gotten stuck with trying to make walls, The player doesnt seem to hit the wall, just keep walking under it!

    I've tried to search for help, but without luck , sorry if there's already a post or a thread explaining what I need to make walls

  • Click on the layout editor on your wall and click left at the table: groups -> attributes --> solid.

    Once your wall is solid, the player wont go through it.

  • Click on the layout editor on your wall and click left at the table: groups -> attributes --> solid.

    Once your wall is solid, the player wont go through it.

    Awesome!!

  • Click on the layout editor on your wall and click left at the table: groups -> attributes --> solid.

    Once your wall is solid, the player wont go through it.

    Now, how do I prevent monsters (bots) from walking throught the wall?

  • How about, making them also solid XD.

    edit: Oh wait, they will go anyway through it...just a second

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Give the enemies, the 8 direction behavior.

    Make an event: for each(you find it at system -> loops) [your enemie sprite] -> start ignore user input(you can find it at the '8 direction-tab(on your enemys sprite))

  • Give the enemies, the 8 direction behavior.

    Make an event: for each(you find it at system -> loops) [your enemie sprite] -> start ignore user input(you can find it at the '8 direction-tab(on your enemys sprite))

    haha thank you so much for the help

  • You're welcome

    If they glitch through the wall anyhow, try to make the wall a bit thicker.

    Happened to me just while testing it.

  • You're welcome

    If they glitch through the wall anyhow, try to make the wall a bit thicker.

    Happened to me just while testing it.

    haha I had that problem actually xD thanks again

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)