Thanks for the information ROJOhound, that clarify everything.
Well, I must suggest changing the name of the expression to "Vertex Displacement X" then, since "Vertex X" logicaly suggest that the returned data would be maybe the relative vertex X position from the hotspot of the object, or relative vertex X position from the top left corner (since mesh points start 0 0 from there), or even the absolute position of the Vertex.
From an usability point, it would make much more sense to have an expression that returned the positions rather than displacements, since positions are much more generic data than displacements.
Displacements are derived data of two positions. But anyway....