V-Sync not Working

This forum is currently in read-only mode.
  • Hey Guys,

    Is there a way to enable vsync in fullscreen-mode? If i run my game windowed i get rock solid and smooth 60 fps which are vsynced. In fullscreen i get 650+ fps that are stuttering very much.

    Why vsync does not work in fullscreen mode? In my graphics drivers all settings are on default values.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Now i have testet all my cap`s on 4 different computer. all with the same result. vsync does not work fullscreen in construct r2.

    is there a way to fix this? i have to release my game in near future and i really need fullscreen support.

  • Is vsync turned on or off on your gfx card settings?.I don't have any problems running vsync in fullscreen mode.What is resolution when you switch over to vsync?.And what operating systems are you testing the game on.If you can make an example cap file then we might be able to help.

  • I also have no problems running vsync in fullscreen mode.

  • It seems unlikely since it's across multiple machines, but try updating your graphics card drivers, that might be the problem. At one point my graphics card refused to use vsync at all and updating my graphics card drivers fixed it.

  • Thanks for your quick replys.

    All computers i have testet it on have Windows 7 64 Bit installed and have newer Nvidia Cards like Gtx560 and Gtx580.

    All Systems are up to Date, DX is up to Date, Drivers too.

    All Settings in the Nvidia Panel are set to default Values.

    Vsync is enabled in the Application settings in my Project and works like it should in Window-Mode. I am trying to run it at 1280x720 px Fullscreen but the Problem is independent from the Resolution.

    To bad i can not post a cap because its from a commercial project we are working on. I have crated a blank cap and startet it fullscreen and the Problem does not exist there. So what can cause Vsync not to work like it should? Its like switching on and of rapidly. Framerates changes from 60FPS to 600PFS ten times a second.

  • My best guess would be to save a copy, then delete events and objects from it in large chunks until the problem stops. If you end up with a blank .cap and the problem still happens, then I have no idea.

  • No problem for me with winxp. Perhaps it's a win7 specific issue?

  • Possible, but it only happens since the r2 Update.

  • Winxp home and pro editions 32 bit = Works fine

    Win 7 Basic and Premiun 64 bit = Works fine

    I tested it with a nvidia geforce 8800 gs card , A mobile ati radeon 5450

    and an Intel hd 2000 card and each one does not come up with any probs ,i have tried to create non power off 2 tilesets and huge textures but i still don't get the framerate problems.

    Try to re install Classic Construct and see what happens.

  • the problem is i can not open my cap files in the stable version. the problem was not there before r2. to bad i have not saved a cap from the stable version

  • Don't panic, just do what Arima said. By eliminating chunks of code/objects from your project, you can find the source of the issue (if any). Then, when isolated the problematic code/object, post here again to see if there's a solution.

  • There has not been any file type changes since 0.99.96, the only difference is the version.

    You should be able to roll back your cap to version r1.2 with this:


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)