can someone help please

This forum is currently in read-only mode.
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • When I export my game which uses python scripting I get

    An error occurred in python, but construct is unable to obtain any error information without StringIO.pyc

    It works fine when I preview it but not when I export it.

    Any ideas... please help.

    I compiled the dx9_s using python 2.6.4


  • johnstiles76

    You've posted this twice now, but the number of people who can answer this are very few.

    I think you'll just have to be patient a little while.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • And the title could be more descriptive to get attention of people who know about the topic.

  • ok thank you,

    Sorry for posting twice

  • That error means StringIO.pyc can't be found/loaded. When exporting, python files are pulled from the .\data\python folder and put inside the exe. If the file can't be found then it can't be included. Another idea is .pyc files are compiled python scripts which only work for one version of python, so if the versions are different the pyc file can't be used. If that's the case then use the python26.dll that's in construct's install folder, that's the dll that's used in previewing.

  • Hi thank you for your reply. I checked and the stringio wasn't in the folder. I'm downloading the data folder from sourceforge to see if it fixes it which I hope it does.

    Thank you

  • Hi Now the StringIO.pyc is included bu I still get the error on exporting

    Please help

  • Hi when I click on StringIO.pyc I get the following error:

    Traceback (most recent call last):

    File "C:\Python26\Lib\", line 323, in <module>

    File "C:\Python26\Lib\", line 283, in test

        lines = open(file, 'r').readlines()

    IOError: [Errno 2] No such file or directory: '/etc/passwd'

    Could this be the problem? if so How do I fix it? Thanks

  • If you're including the file and you're still getting the error then the second part of my answer probably applies.

    Windows explorer says that the python26.dll in construct's folder is version 2.6.2150.1013. Put that dll in the same folder as your exported exe and it should work.

    Edit: It isn't necessary to pm me with a duplicate of what you posted here.

    If you're still having issues you can find solutions yourself by doing small changes over an working install of CC. That way you can isolate what changes introduce the problems and go from there.

  • HI, I still can't figure it out. I tried everything you suggested.

    do you think its a problem with my python install?

    I have python 2.6.4, 2.7 and 3.2.2 installed.

    Should I uninstall them and just install 2.6.4 and choose advanced during install and compile the py to pyc?

    please help...

  • Hi Thank you everyone for your replies.

    I figured it out. it was my Computer. It was messed up some how. I did a new profile on Vista and now it works great.


  • Hi Thank you everyone for your replies. I figured it out. it appeared that there was something wrong with my computer so I setup a new profile on Windows Vista and now it works great.

    Thank you all once again

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)