runtime error

This forum is currently in read-only mode.
0 favourites
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • I am hoping someone can help. I want to try the software so I went to the first tutorial 'Ghost Shooter'. Following instruction I clicked new-Diectx9 game-double clicked the layout-doubleclicked sprite. The sprite designer opens then I get:-

    A window headed- Microsoft Visual C++ Runtime Library

    Inside the window- Runtime error

    Program C:\Programfiles\Scirra\Construct\Construct.exe

    R6025 -Pure Function Call

    I then get the Send an error report to Microsoft window. After sending or not, Construct then closes

  • Whats your PC spec? Processor/RAM/DirectX version/graphics hardware?

  • System is not the newest

    XP Pro SP 2

    512 Mb ram

    NVIDIA GE Force MX/MX400 with 64 Mb ram on card

    Directx 9.22

    Thanks Ashley

    Regards Neil

  • Sorry forgot

    Celeron 1.8 Ghz

  • Hey Ashley, or anyone else interested, got a solution for my problem or not. Please give some response at least.



  • For me, there are only two ways to get such an error []:

    A. You use a Python script and directly call a virtual Function

    B. A bug in Construct which call a virtual declared Function

    Maybe the .cap-File is helpful for a solution

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I haven't figured out why yet but I've had several reports of older graphics hardware (ie. 64MB cards and under) crashing while opening the Picture editor. I'm doubtful it's actually a VRAM issue since the ghost shooter tutorial is unlikely to top 32mb, but I'll try to add some error checking to prevent an outright crash and possibly tell you more information about the problem. Also, could you tell me your screen resolution?

  • Thanks for the responses. Screen resolution 1024 x 768 (32 bit)


  • Ashley, Thanks for the lack of suggestions regarding my problem. I would have been happy with some bull about having to upgrade to be able to use the program, but the total lack of response indicates to me that you appear to be only interested in problems arising inside the program. I still would like to use it and give it a go and will return after my next upgrade to do just that.


  • You didn't pay for this program so to be rude about lack of support for this rare error is disrespectful.

    It's possible that Ashley has absolutely no idea what the problem is but is adding some extra debug code or messageboxes to locate the problem, but to give you 'bull' about upgrading would not solve the problem at all

    By the way, there were some image editor fixes and additions to stop these types of errors. Do you not get an out of VRAM message or similar?

  • You are not the only person in the whole dang world suffering from a "R6025 virtual function call".

    Do not feel special, and do not act as u are. Thx !!

    You can get hit with a "R6025 virtual function call" in every program/application that calls codecs to display content. Not only construct. Its a general error and very specific to YOUR system.

    From the Big AVID Adrelanine to the small Roxio writer.

    I have no "need" to solve this completely for you since you are unneeded rude.

    But here are some hints. Do u have codec packages installed ? (I will not call them by name)

    Do u have an alternative for Apple's codecs installed ? (I will not call them by name)

    Is your QT up to date ?

    Is you Gd up to date ?

    Is your Windows Explorer even showing Thumbnails ? huh ? Without crashing

    have a nice day, eat an apple, thats good for you.

  • Since you wanted a suggestion so bad, send your graphics card back to the archeological trench it came from and buy something decent!

  • I just got nailed with this problem -- though incidently, it worked originally. Left my laptop on overnight with some test stuff open, go up, played some Street Fighter (Non direct-X emulator with and plugging in a USB device), went back to it, went to create a new sprite and got a crash. The only other programs that I used in this time were Firefox and UltraVNC. I tried to reinstall and reboot< which still ended in failure>

    the laptop in question is a Toshiba Protege M200 upgraded to a gig and a half of ram. The built in graphics chip is a Geforce FX Go5200 with what should be 32m of ram. Hope this helps. Guess this thing is sort of pushing the limits a bit.

  • Since you wanted a suggestion so bad, send your graphics card back to the archeological trench it came from and buy something decent!

    Ashley, this is not like you.

  • Neil - "You get what you pay for" like Rich said, the Construct is free so dont complain if its not working. Also try to uninstall and install c++ package thats with construct. (im afraid you have visual installed)

    Captain - Hey Neil is getting on my nerves too i dont blame Ashley, he cant be always nice (plus he have toe broken so probably is making him angrier).

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)