"This file is incompatible with Construct"?

This forum is currently in read-only mode.
From the Asset Store
Source File, music and art pack for Android Negotiator
  • This message comes up whenever I try to open my cap file. Yes, it's the cap and not the persist, thank you very much. It only started happening in the past ten minutes, when it worked as recently as a few hours ago. I have no idea what I could've done to make this happen, but... it sucks.

    All other files seem to be working, so I don't think it's my Construct. Just in case, here's the cap if anyone wants to try and open it.

    http://db.tt/EYyi8iD (EDIT: this is the correct file now )

    It's not HORRIBLY important to fix this, since I have a recent version that I can work back up to the some point, but it would save me a good amount of time if this could be salvaged somehow.

  • Tried to open it, but it shows a missing plugin (spritefont) which I don't use.

    So I can't really help any further, sorry.


  • Opened fine for me using 0.99.97 so I saved a new copy for you to see if it works.


  • Well... this is horribly embarrassing, but for some reason Dropbox wasn't showing the new file I thought I uploaded and I copied the wrong one by accident. THIS is the one giving me problems:


    *sigh* Sorry about that. And Krush, even if you get that message it's probably better than nothing, since I can't open it whatsoever.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah, I get the same error when trying to open that one.

    The only other instance of that happening (according to this site's search engine) is in the following thread, but it was never solved (or even looked at as far as I can see).


    Maybe worth sending Ashley a PM asking him if he'll take a look at the cap file.

    Maybe the header of the .cap file got corrupted, and he might be able to fix it.


  • I don't think the file is fixable. I opened it in a hex editor and it's all zeros. The only option is to go back to the last backup.

  • Wow, all zeroes? Any idea how that sort of thing can happen? I'd like to avoid it in the future if I could, but maybe the best thing to do is just keep really up-to-date backups.

    Either way, thanks for the responses. Better get back to work rebuilding this...

  • I've had something like that happen when I opened a cap from my dropbox folder, and then closed it.

    Something to do with how the cap is changed when the persist is rewritten I'm guessing.

    So basically, don't open from that folder.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)