"A preview is already running!"(Solved)

This forum is currently in read-only mode.
  • All of a sudden, when trying to run a preview, Construct states that a preview is already running. Temp.exe is NOT running, and I get this error even after restarting the computer and re-installing Construct(this happens with new .caps, old .caps, ALL .caps). Also, when I run the preview in debug mode, it actually does run, but it runs a much earlier version of one of my projects(no matter which .cap I am running, it still runs a version of my project that does not exist anymore).

    So I come to the only reasonable conclusion: there's a cache somewhere that's holding onto the earlier version of my project, and that it is corrupted somehow. I then uninstall construct, delete it's program files folder, run Registry Mechanic then install Construct.

    The problem still persists.

    It is keeping that project data I worked on (which doesn't, SHOULDN'T exist) SOMEWHERE and that's frigging up the preview function(at least that's what makes the most sense).

    So I ask ye now, where is the hidden cache folder that's remembering my project and (most likely) messing up the 'preview game' function?

    BTW I'm using the latest version, 0.99.92.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • What comes to mind here is the Windows pre-caching function (can't remember the exact name, prefetch or superfetch or something, must be somewhere in the windows folder). Is it possible that there is something going wrong? I just know about it but never learned much of its working, but maybe this helps?

  • Prefetching only loads files into memory, but doesn't run them. I had this problem once a while ago where I had a loop that started at the beginning of the application, before it even appeared on screen. The loop was running a zillion times, so it seemed like it didn't start up at all. Try opening up the task manager and check the processes tab for temp.exe. Is it there?

  • I've found two locations where Construct leaves files:

    C:\Documents and Settings\USER\Local Settings\Temp

    C:\Documents and Settings\USER\Application Data\Scirra

    ... where USER is your username in Windows. Both are hidden folders. If you're not familiar with those, they can be viewed by setting the option in Control Panel -> Folder Options -> View.

    The first one had a lot of folders with many files in each. The second has a few that are involved with previews and such.

  • Tulamide: I've never heard of prefetching (and it wasn't the case) but thanks for the help anywho

    Arima: thanks for the help, but the first thing I did when it didn't work was check task manager for temp.exe

    Cacophony: Woahz, that second one was it! It had all the data like whether or not to check for updates ect. in it too. I deleted everything in the folder and the preview function now works! (so i guess it WAS glitched/corrupted) Thanks a bundle! maybe this info should be in the wiki.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)