Problems with Families' PV, and a little extra...

This forum is currently in read-only mode.
  • Hi guys!

    I'm trying to make a strategy game, but so far my skills have blocked me from achieving what I wanted!

    However, it seems like I stumbled upon a bug - at least it looks like it - that made me stop for about an hour before I could isolate the problem.

    I made a small .cap so you guys can check it out. It is basically a problem with comparing PVs from families. I remember doing something similar on Village Looter, so I can't say if it's a bug from this version...

    Also, I'm having a stupid problem, that could also be a bug... Instructions for reproducing both are inside the .cap

    Thanks a lot!

    http://www.gamma-beam.com/construct/familyPV_bug.cap

  • Seems to work if you set the PV type to number, though. Perhaps text isn't too suited to "is equal" type comparisons? (Seems weird, though).

    As for the 2nd problem I get it as well, but don't see a reasonable explanation.

  • Hmmm I can't seem to make it work using numbers also...

    I tried changing it here, and on the actual .cap I'm working it was set to numbers.

  • Did you set the type and have it checking without quotes? Anyhow, here's my cap where it works: http://dl.dropbox.com/u/1328856/familyPV_bug.cap

  • Yeah you dont need to define type1, or type2 with quotes. Since your already saying that it is text there is no need. Therefore if you add quotes it will look for them in the comparison, "type1" would have to be ""type1"" then. But it wont even let you use ""type1"" in the comparison anyways.

  • Ouch... Such a stupid mistake! I can't believe I lost an entire morning trying to figure it out!

    It's working great!

    Thanks guys!

    As for the "double-clicking" thing, do you have any idea of what could be causing it?!

  • Im not getting that, I do see a bit of a delay sometimes. Perhaps if you used mouse is over object, or on object clicked instead?

  • I can't do it... I'm using a character to grab things, it's not gonna be with the mouse...

    Update: If I use "On key press" or "On key released" there's no double-clicking bug - this only happens with the "On mouse click" condition.

  • Hey - maybe you need to set the "Click type" option to both single and double clicked. I just realized that some quick clicks may become double clicks and therefore get ignored.

  • It's the System: Compare condition that's messing you up. Use the Blue family "Pick by comparison" condition instead.

    System compare doesn't place objects in the SOL, so you're going to get weird results with it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It doesn't? that could explain a few picking problems i've been having.....

  • I just had this kind of problem with picking the right instance with Families and PVs but changing to Family Compare solved it. "System: Compare Global Variable" doesn't work with family picking either btw.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)