Do not rotate

This forum is currently in read-only mode.
  • I have a sprite with 8 animations for movement in 8 directions, but when I move it (with the mouse using RTSbehavior or with the keys) my picture will automatically rotate. I just want to stay in the position I made it.

    How to do that?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Set "No rotation" under Angle at the bottom of the Object Properties list?

  • Thanks. And how do I remove that little "rotation" effect when changing the direction. I tried the "Rotate object" set to now but nothing happens.

  • Did you assign the different angles in the animator bar?

    For each animation you can have several different angles that are automatically used when the object is at that angle.

    Just select the animation, right click, and select add new angle.

    Also be sure to set the number of angles in the properties tab, on the left side.

  • i cant make it. i created 8 angles for the "Move" animation.

    My first idea (before i discovered the Add Angle) was to set myself what animation/angle to show when the character is moving. The problem is that he still rotates when changing the direction..

    here is the .cap file:

    http://www.mediafire.com/?ow2onmmwyhy

  • You need to re enable rotations, and down at the bottom of that tab set angles to normal, or n angles, then set the number of angles to eight.

    Then you need to call the named animations when you want them to change.

    + spriteFootman: is moving
    -> spriteFootman: Set animation to "Move"[/code:s1xmxhzy]
    
    [code:s1xmxhzy]+ spriteFootman: [negated] is moving
    -> spriteFootman: Set animation to "idle"[/code:s1xmxhzy]
    
    Also when you select the angles animation you can change how fast the animation plays.
  • Done!

    Thanks a lot..

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)