Multiple instances of bone-animated objects?

This forum is currently in read-only mode.
  • Just a quick question; Is it possible to set up a bone animation for an object and then have multiple instances of that object? For instance, if I wanted to have bone-animated enemies, is it possible to spawn multiple copies of that enemy (along with the objects needed for the animation) and have the bone animation still work correctly?

    I just tried setting up a bone animation using two objects and when I made an additional copy of those objects, the first set of objects just repositioned themselves over the new copies when I ran the game. Am I doing some thing wrong, or is this just not possible yet?

    Cheers

  • Just lump all of the pieces into a container. I did that and everything worked correctly. A lot of objects with bone movements(around 10) create a pretty sizable performance hit, though.

  • Just lump all of the pieces into a container. I did that and everything worked correctly. A lot of objects with bone movements(around 10) create a pretty sizable performance hit, though.

    Hmm, I just tried that but it still seems to be doing the same thing

    Could you post a cap?

  • Crap, I think it's broken. I just checked the CAP I made previously(the sample CAP didn't work), and it doesn't work anymore. Once I loaded it up in an older version it did.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ah, damn. Might very well be a bug then

  • Can any of the devs confirm that this isn't working correctly? If so, I'll add it to the tracker

  • Just add it to the tracker anyway. We'll confirm whether or not it's a problem from there.

  • > Just lump all of the pieces into a container. I did that and everything worked correctly. A lot of objects with bone movements(around 10) create a pretty sizable performance hit, though.

    >

    only 10?

    i can run 370 of my ik arms on my 1.8 dual core

    10 seems a tad low. how fast is your comp?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)