Loading a Saved hash table.

This forum is currently in read-only mode.
  • Im using hash tables to load in values for my project. There is an auto save feature that will automatically update the table's save file but I have a problem loading in the saved keys when I load a file on the start of the game when the hash table is loaded none of the keys get loaded in with it. Maybe im just confused about how this should work but I thought that if I saved the keys then I would be able to load them back in. or maybe Im just doing it wrong .

    My basic syntax is

    -on function load -> load hash table

    --If key exists ->set variable here

    but the key is never loaded because the has table will not load...Ive looked in the debugger and there are no keys in the hash table object....

  • I don't think the hash table will load that fast for its key to be instantly accessible... give it some delay and try again?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Even if it doesn't load instantly it should still load eventually. I cant ever access the keys in the hash table they never load no matter what...

  • I just tried a small tester and it worked for me. Where's this autosave feature? Or do you mean your own autosave code?

  • Any load action will always load instantly for the next action unless specified; sounds like a bug to me. If you don't mind, if you can reproduce it or something, put it on the tracker and we'll look into it. Thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)