Issues after updating to .99.42

This forum is currently in read-only mode.
  • Hello all, I've been using Construct and lingering around these forums for a handful of months now, and finally I decided it was time for me to join the ranks! I wish it could be under better circumstances than 'oh crap I need help guys!', but it is what it is.

    So, I'll preface this by saying I'm sorry if an answer to my problem has been posted already... I have tried to search the forums and look around and I can't see anything that quite fits my problem.

    I've been using version .98.9 for a while... things were going just fine, mostly just getting the hang of the thing and making a number of smaller projects. Last week I decided it was time to update to a newer version; I figured maybe it would add some new features that I had been wishing were in there, and maybe it would fix some bugs. So I downloaded and installed .99.42... and this is where my problems began.

    For starters, with this new version, my animations don't seem to work. I don't have anything complicated, mostly just Left and Right angles, but the character doesn't turn. This not only happens with my creations, but also with poor Charlie from Platform School. Even worse, many (or all?) events don't work. My character cannot do anything event-based anymore such as double-jump or crouch. Mind you, through all this I made sure not to save the files in this version of Construct. Just while typing this I realized that perhaps my animation problem is the same as my event problem (seeing as events probably control my animations)... though that doesn't help me fix it

    So, I used System Restore to go back to the day before, when I still had .98.9. When I went to open files, I would get crashes on some of them, and others I would get an error (I can't remember exactly what the error was, but it might have been telling me it couldn't find some sheet... maybe event sheets).

    Finally, when I undid the restore and things were back to where they were the first time I had .99.42 (animations and events broken). Which is where I'm at now. I have not experimented much to see if I create a new game whether it will work or not, but I'd like to be able to use my old events and play my old games. Does anyone have any suggestions? Did I perhaps do something wrong in the install? Also, how do I install multiple versions of Construct at once? Do I just rename the file when it asks me where to save it?

    Sorry for the long explanation... and thanks for any help!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • With the sprites not turning, try double clicking on that event to open up its editor and just click Finish again. Do that for each of the controls that has a 01 in the event where it didn't before. That worked for me.

    Though I did end up leaving the old version installed, and installing the new one in a separate folder because the new additions to the platform behavior seriously messed up one of my games. It wasn't a platform game though, and I just got too frustrated to work on fixing it anymore.

    One note, I am experiencing a weird problem with the double install. The windows for layers, animations, even the Properties one sometimes aren't in their proper position or have to be pulled back up whenever I open 99.42 after having the older version open. Its a nuisance, but a livable option if you just can't reach a work around for updating your games.

  • As MisfitBYTE said, double click the events. Certain conditions/actions seem to have a % symbol added into the mix that breaks everything, but opening and refinishing conditions/actions cleans everything up again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)