Families bug still haunting me!

This forum is currently in read-only mode.
  • Hey!

    So, a while ago I posted a bug report (edit:actually, lucid did ) about multiplying families...

    edit:

    http://sourceforge.net/tracker/?func=de ... id=1003219

    That seems to be solved right now, yet when I downloaded the new version to continue my work, there was a strange problem...

    I noticed 4 groups named "Clouds" on my Object List. They were remnants of the previously mentioned bug, and weren't even on the events anymore. So I decided to remove them.

    When I went to the "Edit Families..." menu, they were not there - only the usual families were present. I tried "Manage Families..." and there they were, the four "Clouds" families.

    Inside each family were hundreds of objects, all repeated (three clouds I was messing with).

    Now I can't delete these families, and the PC suddenly gets slower when I try to do anything with the objects inside them...

    Do you guys have any help? Awesome Dev Dudes?

    I decided not to post this on the bug reports as it is probably something already solved in the newer versions... But if you think I should, then please tell me so I include it there!

    BTW... I didn't notice any problem concerning the game's performance, and the .CAP file size seems ok.

    Thanks!

  • Your project is corrupted by the old family bug. To get rid of old 'ghost' families, you have to do something tricky. Try reloading the project, adding a family, removing it, then saving and reloading again. Experiment, there is a way to remove these ghosts.

  • Thanks for the update Mipey, however this didn't solve it

    Do you think leaving it like that and resume work will be something I'll regret later??

  • Have you tried this on the latest build, 0.99.42? If it still happens, report it to the tracker again.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yes, I'm using 99.42

    However, the .cap was from 0.98. That's why I decided not to put it on the tracker... Should I put it anyway?!?!

  • Yeah, put it up and someone will take a look.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)