EXEs and their DLLs

This forum is currently in read-only mode.
  • Ok so tried to once again get an EXE running on my friend's computer as I had tried before

    after compiling an exe of my recent project I just started in .98.8 (stable) my friend couldnt run it on his computer. I tried putting it on my other computer and as long as I included the XAPOFX1_1.dll it worked perfectly. It had an additive effect and some sine behaviors and 8dir keyboard movement and ballbehavior with rotation behavior. Now when I sent my friend (lets call him steve friend is getting old) an empty direct x exe he could run it, no problem. Next, I sent him an EXE with a blue square sprite object. Also ran ok. Last but not least I sent Steve an EXE with the same blue square with 8 direction movement. BINGO- error! The error read that he needed a "1.csx" file. for some reason his computer, with much better specs than mine and up to date Direct X, can not run a game that uses a behavior. thats a bit strange, any clues on how I can get this fixed? He can run any recent games that require direct X and everything is fine, just the construct behavior exes fail. Windows Vista-likemine- and tons more vram. And what is the XAPOFX1_1.dll for?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • XAPOFX1_1.dll is an XAudio2 DLL. It's installed by the latest DirectX update which he should have been prompted to do when running your game. Did he not see that message? Why did they not update DirectX instead of you sending them DLL files?

    The 8 direction movement thing might be a configuration thing, I'll have a look.

  • Thanks for taking a look sir, I'll be back to check in like...13 hours... sleep and work is important >.<

  • Sorry for the double post, should I put the .caps on the tracker and report this 1.csx bug thing?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)