Driver driver reverts to VGA when I try to use Construct

This forum is currently in read-only mode.
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Hello everybody.

    I tried to follow the Ghost Shooter tutorial to learn this program. I started a New Direct X game. Then double clicked on the layout, then double clicked on Sprite.


    Construct shut itself down and my computer reverted to a 640 x 480 screen resolution with about 16 colors I think. There was a message about not been able to find something. I am sorry but I did not make a note of it. Something like lamart. Then another message came up saying that everything had gone back to VGA. I could not change the display settings back in the display properties box and following the Windows help I rolled back the driver and had to restart my computer. A couple of days later, today, I tried again. Same thing.

    I have got a five year old Toshiba laptop XP Pro. It is A10 Satellite PSA10-05HUMP. It has 64mb of graphics memory. I updated all the directX stuff a few days ago. Today instead of rolling back the driver I updated it from the net, but I think it was just as old as my original one.

    Intel(R) 82852/82855 GM/GME Graphics Controller

    I think that is the name of the graphics stuff.

    Following advice from this site I once again created a new game and checked to see if I've got any pixel shading stuff on my computer. I don't.

    Should I persist? Is there anything I can do? Or should I give up and crawl back to using Game Maker?

    I have tried to give all the information I can and am just trying my best, so please be kind.

    Thank you

  • Hmm, it sounds like you're running out of VRAM, but 64mb graphics memory should be fine to run Construct. Can you not find any newer drivers? Intel generally do really crap drivers for their graphics controllers, and updating them can often fix problems. If your drivers are really five years old, that's not going to end well in DirectX 9 apps.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You might be able to find newer drivers here: ... 2&lang=eng

    That's for the chipset you're using, but the last update was in 2006. Still, that's better than five years old.

  • Thanks very much Ashley for your help. I have looked at that driver link. Excellent. I had got my driver from the Toshiba site. I was afraid to say this but when I looked at the date of the downloaded driver it said 2000! So I am very pleased to find a 2006 driver from the link you gave. Whatever happens with Construct, I am very happy to be improving things on my computer.

    Will do that download now, install it and go through the restart business. Then with fingers crossed try getting a sprite happening! I'll be back at some point to say how things have gone. Thanks again.

  • let us know how it goes, updating drivers is always a good thing

  • Hello everybody, thanks for your interest.

    I am close to giving up. I downloaded the driver and then when I tried to install it, it said it was not suitable for my computer. So I went back to the Intel site and let them do a graphics chip detection thing. The result was that my driver is a customised version and I should contact Toshiba for help. I have been back to the Toshiba driver page. I wish they had an automated detection process. Maybe I downloaded the wrong one from them. I mean right for my computer, but not even a display driver. But it is called display. Then I downloaded a 'chipset'. That didn't help. I have got a more detailed error report this time:

    Open up new direct x game

    Double click on layout

    Select Sprite

    Nothing happens, but there is a cross hair cursor on screen

    I get bored of nothing happening and click on the screen

    Picture Editor opens up and then BANG, it's all over red rover. Colors go to 4 bit, resolution 640 x 480

    Message comes up saying

    Windows - Display Driver Stopped Responding

    The ialmrnt5 display driver has stopped working normally. Save your work and reboot the system to restore full display functionality. The next time you reboot the machine a dialog will be displayed giving you a chance to upload date about this failure to Microsoft.

    Then I can't change things back again, or if display properties does let me move the slider along to change resolution, and say ok, the screen goes black and eventually I press the off button. Then when I start up I get all sorts of bother trying to fix things up again.

    I see from a quick search that others have had a problem with the ialmrnt5 display driver. My brain has had enough for now and I am tired of restarting my computer over and over. I will look into it when I can face it. But on the quick look I've had, it seems to always suggest updating drivers to sort it out.

  • Email Toshiba tech support and ask where you can get the latest drivers for your graphics chipset (provide them with all the hardware info you've got, including the laptop model, and all the info you've posted here). If they can't give you an up to date driver, I wouldn't buy from Toshiba again. It sounds like your driver is crashing, and if they can't provide an up-to-date and DirectX 9 compatible driver, they really suck, because that means you're stuck and can't use Construct, and that would be Toshiba's fault.

  • Yay, I am officially excited! I've got Construct working!

    Yes, Ashley, it sucks about no driver support from Toshiba. That one on their site is 2003, not 2000 as I said previously. It was the setup file that was from 2000. Still sucky though.

    I downloaded a thing called DriverMax. It looks at your system, compares your drivers with those in its online database and tells you what's out of date. Then you go through a bit of a complicated process to download them and have Driver Max install them. It found a new graphics driver for me and three other assorted graphicy type things. I did not expect the Intel graphics driver to install, but it did. It is 2006 and is shiny and new compared to my old one. And Construct works. Still no pixel shaders though. I haven't gone past drawing a few lines in the graphics editor as I wanted to write this message.

    If anyone finds this post because of similar problems and is wondering about updating their drivers, here is some info. There are other driver update programs besides DriverMax. Don't bother with Driver Detective. It tells you what you need, but then tells you that to get the drivers you must pay them. There is a free one called Radar Sync. But it would not recognise that I was connected to the internet even though I was. Other people have had the same problem. So I never got to use it to find out if there was a catch. The catch with Driver Max is that after registration (totally free) you find out that you must give permission to upload your drivers that need updating to their database. In my case one was 4mb and the others were only a few k. So no problems there. But they do spring it on you at the end. All the driver update programs are about a 5mb download.

    I would recommend DriverMax, but I find it sad that there is a need for such a program. Unfortunately in my case there was.

    With any luck my next topic post will be something actually related to using Construct. Thank you for your encouragement with nailing the driver situation.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)