How can I disable the "ALT" pause key?

This forum is currently in read-only mode.
  • Hello everyone!

    I've a problem.

    When the game is running, the game pauses when I press the "ALT" key.

    Especially, in a platform game, the game glitches.

    How can I disable the "ALT" pause key?

    Thanks!

    Bye!

    Example file:

    box.net/shared/omez9tpjnymb5r30k5v6

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • The "pause" happens, because "alt" is a system hotkey that sets the focus to the window's system menu (restore, minimize, maximize, exit, etc.) This menu exists if the window has a caption bar (it is the one you get if you left click on the icon in the title bar, or rightclick the title bar). So the quickest way to prevent this behavior without python or some plugin is to disable "caption" in Application Properties/Window Properties, or to go fullscreen.

    To be honest, this is the first time that I see this behavior. It is an issue that should be avoided by Construct if possible.

  • Haven't come across this before, but you could click on 'Manage Controls' when on Project, and add a new one for ALT.

    *** Damn. Ninja'd by Tulamide.

  • Thanks both for the answers! :)

    For Zenox98: The solution is valid only if I press "ALT" key, because I've discovered another pause key "F10".

    Tulamide: Thanks a lot!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)