Crash on preview. [SOLVED]

This forum is currently in read-only mode.
From the Asset Store
Minimalist Crash Balls is a game where the goal is to hit the ball on the portal, with 20 different levels :)
  • The problem i experienced has been solved.

    The cause for the problem is still unknown to me, but it appears that somehow the fonts became bugged. And i don't just mean the resource plugin i used, i mean that even the windows font viewer was not functioning (displayed empty lines). Either way, a restart fixed the problem, everything now functions as expected, it appears that the drag and drop action did absolutely nothing. As for the files, i've removed them, as my programming is nothing i'm exactly proud of, except for the archive with the plugins and effects - i foresee many of the links to them becoming broken and it's possible that someone might come across this thread and find links to the downloads of good use. Either that, or you could just want to randomly download a set of plugins and effects i've deemed to be okay (i'll keep telling myself this and you just agree that i didn't just waste both forum space and your time). Anyways, that was a perfectly good hour - wasted. At least i learned a bit about how to troubleshoot better.

    I'll keep this short.

    I've recently started working on a little project of mine: a top down game. Well, the details are irrelevant, really.

    After working on it for a couple of hours, i ran into a problem. As i was moving a couple of objects (in the Default folder) to another object folder (Menu), i accidentally let go of the mouse at one point. I don't know what happened, as it didn't appear to do anything at all, however i'm probably wrong, because i could no longer preview the project. As soon as the preview loads, the application crashes, with the following message:

    "Temp2.exe has encountered a problem and needs to close. We are sorry for the inconvenience."

    Pretty generic, huh? So, i copied over the contents of that little information error:

    I also get an error prompt when i close the game:

    "Runtime Error!

    Program: ...Settings\Administrator\Application Data\Scirra\Temp2.exe


    -pure virtual function call"

    However, i doubt that this is to blame, as this error also popped up whenever i ended the preview normally (by either clicking the close button of the game window or using the system action), and it didn't appear at any other time.

    Either way, everything appears to be fine in the event sheet and layout editor, i can't spot anything that i've done wrong, but i'm certain that it has something to do with me releasing the mouse when dragging one of the objects. If i remember correctly, i released the mouse as it was over another object. What could have happened? Is there any way to fix whatever occured?

    Do not suggest that i update my video drivers or something else that's comparably generic (such as reverting to a backup, i don't have one), as everything worked just minutes prior to whatever i did. Here's the .cap file, don't laugh at me, i'm no artist:

    Thank you for your time.

    Update #1: i was using r2 when this happened. The project was created and modified only in this version. No other changes were made directly to its files or whatever. Also, here's a .7z archive of every single effect and plugin i use, just remember to back up your folders when you add these (although they never crashed before this):

    Update #2: it appears that the crashes are caused by the MainText object. Removing it solves the problem, however this is not something that i can just do, as most of my progress revolves around these objects. Is there a fault somewhere in the event sheets or has something gone wrong in the layout editor? I await your response...

    Update #3: it appears that the problem is in the event sheets, as disabling all the events allows for the game to be run without the crash, trying to toggle groups back on one by one to find out more specifics...

    Update #4: i've pinpointed the crash to the event "On function "RefreshText"", under the group "setupFonts". Trying to find out more about why this happens.

    Update #5: the custom fonts aren't loaded anymore by the resource plugin. Trying to change to them generates the error. No idea why. Size and color changes work as expected. After some more testing, i've concluded that all of the custom fonts have ceased to work, they are either not extracted correctly or there are problems with loading them into the memory. I await your ideas on how to fix this, or any workarounds you can offer (but i need these fonts).

    By the way, here's the .cap file with the responsible events disabled. Enabling them causes a crash (at least on my machine, for all i know):

    Update #6: new error:

    "Construct encountered an error in the display engine. Please report this problem to the application developer.

    Failed to create render target texture (0x8876017c)"

    This error appears whenever i try to preview the game after deleting the Resource plugin. Furthermore, even if i don't touch it directly, it still crashes if i remove the actions that extract the font resources and load them, even when the actual events that are supposed to set the fonts are disabled / are non present. Weird. Is this just me? Any ideas?

    Update #7: upon re-opening construct, i can remove the Resource plugin without problems. It seems that having 2 instances of construct open could be the cause for this, but other than this, i have no idea why it didn't work just 30 seconds ago and does now, either way, i still need to find a way to restore the functionality.

    Update #8: confirmed. "Load font" indeed crashes when more than 1 instance of Construct is opened. What weird software this is... :/ Still working on the fix.

    Update #9: problem solved. Updated the top of the post.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)