Construct and Macbook Parallel

This forum is currently in read-only mode.
  • I've introduced a friend of mine to Construct and he's running Parallels on his Macbook. His other PC-only apps all work perfectly, yet when he tried to create a sprite in Construct, no luck. Upon opening the sprite editor window, he sees his empty sprite in the centre, but can't draw on it at all. There is also a completely black copy of the empty sprite in the upper left corner of the window, very strange. He also demonstrated to me trying to create a button. He creates one, it shows up on the object list, but not on the layout. Even dragging it from the list shows nothing on the layout. Yet, at runtime, they appear and function normally in the program window. Any ideas?

  • Not only that. When I try to use Construct in Parallels on my PC with the Magic Mouse, I can't drag any of the objects. When I left click, it only moves the layout.

    I tihnk for now, the only way is to install Boot Camp and Windows or use a pc.

  • Construct uses a pretty recent version of DirectX. My best guess is they haven't got decent DirectX support. Nothing we can do about that sadly.

  • He says he downloaded and installed the most current version of Direct X just to try and use construct

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That still doesn't help if Parallels doesn't support DirectX fully. Only if you use Boot Camp than it would work.

  • I told him to try Boot Camp and see if it works. Thanks for the help guys.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)