Construct install issues on windows 7 64bits [Solved]

This forum is currently in read-only mode.
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Hi,

    Sorry to start my forum life with a request for help but I've tried a lot of things before coming here, and this is getting frustrating.

    On my 64 bit windows 7 laptop, when I install Construct, all goes well until I reach the DirectX prompt, it then tells me that I should check if cryptography services are running, and then that the install is not complete.

    Then when I still fire up the Construct icon, it tells me that the program cannot launch because it's missing a Xapofx1_1.dll

    Which is strange, considering that windows seven is supposed to have directX11 preinstalled.

    What's more I have other DirectX apps running fine on this system.*

    Soooo , has anyone met this issue before ?


  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I am running on a windows 7, 64bit machine. But I couldn't upgrade, i am still working fine with v 99.62. try back tracking and see if it helps. I am not sure where to find older versions, but i think i still have the install file if you need it.

  • As far as i know the DirectX 11 that comes with Windows 7 does not include DirectX 9, and it must be installed manually.

    Try installing this: ... laylang=en

  • I've installed Construct fine on a Windows 7 64-bit laptop, it must be an issue with the DirectX installer. And yes, DirectX 11 does not include the "optional" components of DirectX 9 which is what the installer is installing. Try just cancelling the DirectX installer and installing it from the Microsoft website maybe?

  • Thanx for the help guys.

    Turns out DirectX was the problem as I tried the directX 9sdk web install the same problem appeared. The issue was with a cabinet file not being approved, which is odd considering DirectX is a microsoft app, in my case it was the november 2007 cab file. I deleted it and fired up the webinstall again, and after it downloaded the missing file all worked well.

    Here's the link to the webpage that helped

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)