Construct glitch? maybe

This forum is currently in read-only mode.
From the Asset Store
Casino? money? who knows? but the target is the same!
  • Ok so last time I made this post there were 80 views, no replies. How depressing. Anyway maybe I just didn't present it well. In this game there are lots of rooms. In each room is 4 power sources and 1 computer and at least 1 door. when you turn on all the power sources and then activate the computer, it opens the door. Simple! its worked for 4 rooms so far. but upon adding the 5th room the game glitches and only the first two rooms seem to work. Can anyone help me with this? Here is the .cap file.

    Try to activate the first 3 rooms. They should work. Then add another computer, 4 containers, and a door. Change their "ID" values to 5 and try to activate rooms 1-3. the Third room should not work. This is the problem I run into. I cant add any more rooms until I figure out why it does this!!

    Controls: Left/Right Arrow= move left and right, Down/up arrow=prone and getup (also moves elevators up and down), X=jump, C=fire laser (you have to shoot the containers before being able to use them), UP arrow activates things

  • That's really strange

    I can't understand why it would do that. I even changed all the ID numbers to wacky stuff like 47 or 849 and that 3rd computer just won't work. The 5th one that I added doesn't work either, but the 4th one still does.

    Then I deleted the broken 3rd computer and made a new one, and it worked fine after that, but the 5th one still didn't.

    I have no idea what's going on. There's something glitchy at work here.

  • Yeah its so confusing, I know I didnt comment my events, just organized them. But it doesnt seem like any of them would break it at 5... man this is sucks. maybe ashley and friends can take a look at it.

  • BUMP! come on Ashley, or David.. someone. I need help

  • I can't figure out what to do. I tried pressing up on the buttons and nothing happens. I tried shooting them all and still can't get the door open.

    It's much easier to deal with bugs (or questions about code) if you can reproduce them in a blank .cap file.

  • You have to first shoot the switch, then push up when you're overlapping it to activate it.

    Honestly, it's kind of redundant, I think. It seems that either just shooting it or just turning it on would suffice in activating it. But that's got nothing to do with the bug, it's just my personal opinion on the gameplay

  • So now I run to the end and there's just a barrier in the way. I don't know what to do next.

    I don't really have time for playing my way through games/finding my way through events lists to solve complicated problems - I'm stretched for time enough as it is. If you want me to have a look at what you think is a bug, reproduce the problem in as simple a way as possible and make a .cap out of this (just use a bunch of sprites you click on to simulate power ons and doors or something, so its just a handful of events).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ok, I apologize. When I get the time Ill try to make a reproduction. Thanks for looking at it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)