I can't play the music in my game

This forum is currently in read-only mode.
From the Asset Store
A complete set of Graphic, User Interface element to build 2D mobile game or PC game.
  • I tried to used the XAudio2 to play the background music. But, i don't know, it always won't play..

    At Event sheet, i use (Start of Layout) and then the action is (play music from file).. I type (AppPath & "My Music.mp3"), when i tried it, there's still no music..

    Please, anyone can help me? I'm still new with the Construct..

  • I tried to used the XAudio2 to play the background music. But, i don't know, it always won't play..

    At Event sheet, i use (Start of Layout) and then the action is (play music from file).. I type (AppPath & "My Music.mp3"), when i tried it, there's still no music..

    Please, anyone can help me? I'm still new with the Construct..

    Make sure the file 'My Music.mp3' is in the same folder as the cap file.

    If its in a sub folder you would need the path, eg AppPath & my sounds \ My Music.mp3.

    Hope you sort it.

  • I'm with the same problem, it doesn't play the music but if I compile the game it plays, so I'm kinda confused, Construct doesn't play the musics while testing the game? Only after compiled using the .exe file?

  • I'm with the same problem, it doesn't play the music but if I compile the game it plays, so I'm kinda confused, Construct doesn't play the musics while testing the game? Only after compiled using the .exe file?

    Happens here too still. Got to be a bug.

  • Would you mind uploading the .cap and the music? I'm interested in this, as MrMiller experienced it exactly the other way round, whereas I never had any issues.

  • I actually discovered it's because I was previewing it in Chrome. I switched to IE and it works. Here's a capx....it's set to IE. Preview and you'll hear the audio but change it to chrome and no audio plays:

    dl.dropbox.com/u/10196246/Chrome%20Sound%20Preview%20Problem.capx

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Update: Ashley says it's because I was trying to play an mp3 in Chrome. Only IE and Safari play those. Solution: Use wav instead.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)