Can't debug or run applications

This forum is currently in read-only mode.
0 favourites
From the Asset Store
Full game Construct 2 and Construct 3 to post on Google Play
  • Hello, I'm very new and I just started with construct. So I opened an example to see how everything is. First I clicked "Run all" then this message popped up with this message...


    Runtime error

    Construct encountered an error in the display engine. Please report this problem to the application developer.

    Fail to create Direct3D 9 device. (0x8876017c)

    Then I clicked "Run Layout" and still the same message. Then I thought I might need to debug it first so I click "Debug all" and "Debug Layout" and still the message popped up so I thought it might just be a problem with the application so I tried another one without success.

    HELP ME!

  • Seems like a vram error.How much megs does your gfx card have?.You could try to update your gfx card's drivers or get the latest directX drivers.



  • So what do you want me to download. I currently have DirectX 9.0

  • First of all, does this happen with the application runtime? (File -> New -> New Application)

    What are your system specs?

    Also, try re-installing DX9, especially if you're on Windows 7.

  • Go to start menu and then go to run, type in dxdiag that will determine if your directx files are corrupt or not.Look for any missing or corrupt dxd9 files .If there are files missing on the directX files tab then you need to reinstall directX9c.Try downloading a new driver for your gfx card first.

  • There are no drivers for my graphics card and I've reinstalled Direct X 9 about 3 times today.

    I might have been downloading the wrong thing. Someone give me a link.

  • What graphics card do you have? Nvidia ,Ati Or onboard GFX.Without any Technical specs there's little we can do to help you out.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • [quote:2hb0hw9q]


    Display Devices


    Card name: RAGE 128 PRO Ultra GL AGP (Microsoft Corporation)

    Manufacturer: ATI Technologies Inc.

    Chip type: RAGE128 PRO II, (AGP 4X/PCI)

    DAC type: Internal DAC (350Mhz)

    Device Key: Enum\PCI\VEN_1002&DEV_5446&SUBSYS_04081002&REV_00

    Display Memory: 16.0 MB

    Current Mode: 1024 x 768 (32 bit) (60Hz)

    Monitor: Default Monitor

    Monitor Max Res:

    Driver Name: ati2dvaa.dll

    Driver Version: 6.13.0010.5019 (English)

    DDI Version: 8

    Driver Attributes: Final Retail

    Driver Date/Size: 4/14/2008 01:11:49, 377984 bytes

    WHQL Logo'd: Yes

    WHQL Date Stamp: n/a

    VDD: n/a

    Mini VDD: ati2mtaa.sys

    Mini VDD Date: 8/3/2004 23:29:28, 327040 bytes

    Device Identifier: {D7B71EE2-1706-11CF-2960-0224A2C2CB35}

    Vendor ID: 0x1002

    Device ID: 0x5446

    SubSys ID: 0x04081002

    Revision ID: 0x0000

    Revision ID: 0x0000

    Video Accel: ModeMPEG2_C ModeMPEG2_D

    Deinterlace Caps: n/a

    Registry: OK

    DDraw Status: Enabled

    D3D Status: Enabled

    AGP Status: Enabled

    DDraw Test Result: Not run

    D3D7 Test Result: Not run

    D3D8 Test Result: Not run

    D3D9 Test Result: Not run

    Now what?

  • ooh need to upgrade that video card,You need at least 64 megs of video ram to run CS if im not mistaken.Display memory must be at least 64.0 MB

  • Indeed, that video card is far too outdated for Construct I'm afraid. You could probably upgrade, but AGP cards are becoming less and less common now as most use PCI-E. Would also need to know what power supply you're running as a new card will draw much more power than that one.

  • Sad really. This seems so much better than game maker. I'm on an Optiplex GX260. I could download it on another computer but I hardly get to spend time on that one.

  • Download it on that other computer then ,Believe me you won't be dissapointed.Construct Is the best program ive ever seen so far.

  • [quote:cgre9aqr]

    Optiplex GX260


    A 2002 computer and it's never been upgraded? How can you even browse the web on that these days?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)