Bug in 360 controller?

This forum is currently in read-only mode.
  • Latest build 0.99.85 released (unstable).

    Need some help here cause I'm going nutty! If you look at my .cap below, it appears the the 360 controller defaults to a button press I believe in "A" at runtime, when I was testing out my button presses "A" caused the character to jump even though I set that action to "B". Please have a look and see that State2 is set to 1 at runtime then switches to "0" (default) briefly when the sprite hits the ground, then it sets the State2 variable back to "1". Is this me or the controller? The State2 variable is supposed to be "0" at runtime until I attack which kicks it to "1"

    Thx for any help

    http://www.thecareergamer.com/web/prototype_brawler2.cap

    ~t

  • gambit wouldn't move at all for me. I may not even have the latest version. even if someone does/does not duplicate the bug, however, a stripped down cap with only the problem, and almost nothing else is the best way to test possible bugs. it's difficult and time consuming to hunt through a large cap for the code relating to a specific thing like 360, or a state variable, let alone the piece that might be causing the problem, if indeed it isn't a construct problem

  • Sorry I should've mentioned the line that was causing the issue and such. I think I'll basically start a fresh project and test again.

    It's line 21 btw, and I changed playerMsk: Value 'state2' Equal to 0 to (Equal to 1) that seem to work, but my "A" button still believe it's a jump state... anyhoo I'll keep trying, thx for looking at least.

    ~t

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • btw, does this work for you: (does for me)

    http://dl.dropbox.com/u/1013446/workin360.cap

    doesn't necessarily mean other ways of accessing the button will work, like the buttonstate expression

  • Ok so I added a few more button presses, looks like there's something funky in the logic I was using... time to scrap and start fresh!

    Here's the updated .cap http://www.box.net/shared/1qsrgm9gja

    thx again for the help...

    ~t

  • btw, does this work for you: (does for me)

    http://dl.dropbox.com/u/1013446/workin360.cap

    doesn't necessarily mean other ways of accessing the button will work, like the buttonstate expression

    OK that does work!

    But in older construct builds you could just have a car movement and just add the 360 controller and it all just worked automatically. So you now have to set up everything?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)