3D Box question - Missing lid?

This forum is currently in read-only mode.
  • I'm not sure if this is just a limitation sort of thing or something to do with my computer, but the 3D box object's "front" texture seems to not appear during the run time. Is there a way to fix this?

    Also, the 3D model object, although I don't really plan to use it, seems to be see through in some areas when I put a texture on. I'm not a modeller, so I'm probably missing something obvious here...

  • Have you enabled 3d layering?.Click on the layer and on the left hand side there should be a 3d layering option ,Make sure that it's ticked.See image below.

    <img src="http://dl.dropbox.com/u/7658043/layer3d.jpg">

  • Hmmm... that does make the "front" texture render, but know the other sides seem to flicker as I move the character about, from black to transparent to it's original texture. Could this be an issue with my computers lack of memory? I'm running on a laptop...

  • are the textures jpg or png format textures?.post the cap ,and i will see what i can do

  • Here's a link to the game. I only started building it this morning, so it's a little rough...

    http://www.mediafire.com/file/76ud5r84c ... marine.cap

    I know this is a little off topic, but if you do go through the cap I was wondering if you could give me some feedback on whether it's any good...?

    EDIT: Oh, and I just quickly drew the textures on the image editor. I didn't want anything complex, just a basic pattern that wouldn't look too distorted if I stretched the object. I'm not sure though now that the 3D box option is best for a wall anymore...

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I have tried but to no avail , Looks like another bug construct has with 3d boxes.The game looks great thus far.I will try to find alternative ways to create 3d walls and will keep you posted if it can be fixed or not.

  • Thanks for the help. All of your tutorials and examples are also greatly appreciated!

  • found the problem , Clear Depth buffer must be ticked as well on the main layer.

  • Aha! Works like a charm. Thanks for the help!

  • No problem.Good luck with your game

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)