Which version of Visual Studio should I use?

This forum is currently in read-only mode.
0 favourites
From the Asset Store
This music pack covers differents situations for visual novels, anime games and many more!
  • I've just checked out the source from CVS, and can build Plugins/Runtime/SDK projects with my Visual C++ Express Edition (with MFC enabled), but failed to build IDE project. Visual Studio crash everytinme when I tried to build IDE project.

    I wonder which version of Visual studio should I use to build the IDE project? Visual C++ 2005 Pro edition? or Visual C++ 2008?

    Any help would be appreciated.


  • This may not be a helpful answer but I use dev-C++ and it's been a blessing to me.

  • i think 2008 is better and suggested by ash somewhere in the dev bit.

  • The IDE builds in VS2005. Everything else should be VS2008. I don't know what would make Visual Studio crash - better take that up on Microsoft support somewhere :-\

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks for all the responses.

    I found out that Visual Studio crashed when compiling "resource.rc". If I remove "resorce.rc" from IDE project, all other files could be compiled without problem.

    I manually compiled "resource.rc" with Rc.exe, and tried to rebuild the IDE project, but after all files been compiled, there's a linker error say "ProfUIS283yn.lib" is missing.

    Since I can only find "ProfUIS283ym.lib" and "ProfUIS283ymd.lib" in the LIBs folder, I just copy ProfUIS283ym.lib into ProfUIS283yn.lib, and now everything could be linked, "Construct.exe" could be generated finally. But... My constrcut.exe won't run

    I went to Prof UI and downloed the builded the 2.83 freeware Library, but still can't get the ProfUIS283yn.lib". I'm stuck, and have no idea what i did wrong?

  • For what it's worth - and it may not be helpful - I installed Visual Studio 2005 on a freshly formatted laptop, checked out and it compiled first time; can you confirm you are trying with 2005? Also, are you using a 64 bit version of Windows; do you have the correct DirectX SDK, etc..

  • I'm using Visual Studio 2005 express edition at home, and my windows is not 64 bit, my DirectX SDK version is 2007 Nov. Should upgrade my DirextX SDK?

    I also tried Visual Studio 2008 Pro which I used at work, but the problem is the same.

    Rich, I wonder how can you compiled the IDE project the first time? As I remembered, there's one one cpp file (cant recall which file) which contains one line of code missing one double quotation mark. Maybe you checked out an earlier version?

  • No, the first checkout compiled with 2 warnings, 0 errors, which is odd if you have a double qoutation error. Which file was it in?

  • It's "Animator Bar.cpp"

    Line 877:

    AngleName += "?;

    It seems like a non-ascii character. When I using web browser to view the file in repository, that line is:

    AngleName += "?";

    Don't know why the last double quotation is missing after checking out.

  • That line for me reads:

    AngleName += "�";

    That's a degrees character - a small circle to denote an angular measurement.

  • And the problem would be with unicode character support on MsWin?

  • That line for me reads:

    AngleName += "�";

    That's a degrees character - a small circle to denote an angular measurement.

    Yes, I can see that is a "�" in the repository page: "http://construct.cvs.sourceforge.net/viewvc/construct/IDE/Bars/Animator%20Bar.cpp?revision=1.25&view=markup"

    But after I checked out it just became "?;

    My question is, I can build the construct.exe, but it won't run. I can only guessed it's either because I used wrong version of prof-ui library or I has compiled resource.rc in a wrong way. But as u can see, I have no idea how to figure out.

    Any suggestion?

  • Run a debug and see why it wont run?

  • Run a debug and see why it wont run?

    Yes! FInally it works!

    The problem is when I building resource.rc with rc.exe, I missed to define "_AFXDLL" symbol. After I added paramer: /d "_AFXDLL", everything works fine then.

    Now I'll move on to learn how to make a new plugin. Should be fun

    Thanks guys for your help!

  • Hello Midnight and Hello Everybody

    Happy New Year

    Midnight wrote:

    This may not be a helpful answer but I use dev-C++ and it's been a blessing to me.

    Please kindly explain how to go about using dev-C++. I will like to use it or code::blocks to complie Construct. I have both on my system, but what are the requirement for using dev-C++? Can you send me dev-C++ project file? or link to download it if possible -- Thanks.

    Any help, advice, pointer given on this will be highly appreciated.

    Happy New!!!

    God blesses!!!

    Best regards,


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)