(Not) Using Construct with WINE or VMs...

This forum is currently in read-only mode.
0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!
  • It seems that - so far - this isn't possible, at least with Ubuntu 8.10. WINE 1.0.1 and VirtualBox 2.1.0.

    With VirtualBox and 2k (assigned 512MB RAM plus 128MB for graphics), the layout editor complains about a lack of available memory. VirtualBox has only recently started to support 3D acceleration for VMs, and that (so far) only under XP. KVM/Qemu doesn't support 3D acceleration (and won't as it emulates a mid-90s Cirrus Logic graphics card). Haven't tried VMWare Player, so I don't know how well that'd work.

    With WINE, the installer itself runs correctly until it reaches the DirectX websetup tool, which crashes. The Visual C++ Runtime doesn't install or work correctly under Ubuntu 8.10's version of WINE, so even running the physical (XP) machine's copy of Construct does not work (after using winetricks to install DirectX).

    As to which one might end up being able to support Construct first, I actually hope it's WINE (after fixing the DirectX installer problems), although either would be nice.

  • A small update:

    Construct sort-of works with WINE 1.1.12. The File menu is non-responsive and it seems to crash loading (at least) a test CAP I made the other day (with the physical machine XP), but it got somewhere more than with the other version.

    Games made with Construct appear to work though. No sound under WINE 1.0.1, but they do have sound with 1.1.2.

  • 0.98.4 is still broken (WINE 1.1.2; 1.0.1 gives a "Call from 0x7b845450 to unimplemented function dwmapi.dll.DwmFlush, aborting" error).

    I followed stainsor's advice in . On startup, it reports that "Error loading C:\Develop\Construct\Plugins\ID3.csx (126) - this plugin may not be available!" and "Error loading C:\Develop\Construct\Plugins\Registry.csx (126) - this plugin may not be available!". These two initial errors can be fixed by copying MFC42.DLL into WINE's windows/system32 directory.

    Loading up a test .cap either fails when trying to run it via Construct with a "Cannot find XAudio2.csx" error, or crashes out due to what looks like problems with OpenGL's SetDepthStencilSurface function...

  • I wish I had an apple to test it on...

    If you create a blank direct x game does it run?

    If you place just a single sprite on the layout does it run?

    If you then add an action like 'rotate 1 degree' does it work as expected?

    Is it just those plugins which are having a problem?

  • David: I can't get the menu to respond. It appears but I can't click on anything. Keyboard shortcuts appear to work though. The bottom half of the layout window acts like a black hole. The context menu also does not respond to mouse clicks. Interestingly, it does respond if you use the cursor keys. However, positioning doesn't work.

    It comes up with a lot of:

    fixme:d3d:IWineD3DSwapChainImpl_Present Unhandled present rects (0,0)-(1142,792)/(null)[/code:2ti47djl] and [code:2ti47djl]fixme:d3d:WineD3D_ChoosePixelFormat Add OpenGL context recreation support to SetDepthStencilSurface[/code:2ti47djl] and [code:2ti47djl]err:listview:LISTVIEW_WindowProc unknown msg 1091 wp=ffffffff lp=0032c050[/code:2ti47djl] so it's apparent there are known shortcomings with this.
  • I'd imagine Wine is rather good with the standard Windows API, but it's to be expected it may not perform as well on custom UIs (which rely on callbacks, overrideables, etc). You should submit bugs for Wine for these problems, and then maybe.. one day.. Construct may run perfectly .

  • Except they already know about two of them, judging by the "fixme"s.

    Doesn't mean that I won't submit bugs though - I couldn't find Construct on Wine's application database, so it looks like nobody there either knows of it existing.

    The video hardware tool doesn't work either.

  • Part of the problem is probably that Construct is using the very latest DirectX updates at the moment (eg. November 2008). As it seems WINE and other emulators have poor DirectX support off the bat, I doubt they're able to keep up with such updates.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well, WINE no longer complains about OpenGL features when it crashes Construct (0.98.6). Just complains about the X11 renderer now.

    Dunno if that's an improvement though. If it's just a WINE bug that's keeping Construct from working(ish), then that's at least something.

  • You could try informing the WINE project that WINE doesn't work with Construct. They might be able to fix it then.

  • The crash detail seems to include something about accessing the internet. Have you tried disabling automatic update checks? Change UpdateCheck=1 to UpdateCheck=0 in Construct.ini (C:\Documents and Settings\<username>\Application Data\Scirra) to disable.

  • Changing that value makes no difference whatsoever. Setting the Theme option to 0 seems to get a little further along before it crashes.

    Looking at a crash log it talks a lot about WineX11 and XRender.

  • I'd definitely put money on it being our UI lib being the issue, so that's something Wine needs to work on.

  • From Googling I do get the impression WINE has issues with Prof-UIS, yes...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)