Contruct crashes when importing animation frames

This forum is currently in read-only mode.
From the Asset Store
Ninja char for your game! Make your own Shinobi game with this art.
  • I made a video showing step by step what happens whenever I try to import an animation (using the "Import Frames" option) into Construct, here:

    I suggest you watch that first, since it speaks for itself or at least much more than I can.

    Anyway, as you can see. I open Construct. I tell it to create a new Direct X game. I then try to add a sprite (and leave it blank, although it doesn't matter anyway).

    Then I click on the sprite, try to import frames into the Animation Bar, click on/hover over the Animation Bar and then viola, everything goes to hell. The main window crashes and everything goes haywire.

    I then try to save my file (hoping that I can recover something) and open it and I end up with nothing more than a corrupt file.

    (By the way, ignore the part where I accidentally open the insert object menu while it is glitching. I pressed something by accident in the confusion. That has nothing to do with anything.)

    Edit: By the way, here are the images I tried to import into Construct if you need them:

    Edit: Actually, ignore my previous edit. It seems like it doesn't matter what images you use. If I try to import ANYTHING, it causes the same behavior. It hangs regardless of what the image is. That is regardless of size or file type or anything. It just seems to hang and go haywire whenever the "Import Frames" option is used to import something.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Did you solve this ? and how ?

  • No, I didn't. Moreover, I can't. It's a bug in the code, deep with in the program itself. I'm just reporting it so that Ashley can fix it.

    But on a side note, if you want, you could help out by trying to see if you can reproduce this bug on your end. Follow the steps I showed below or even just try using the "import frames" option on the animation bar and tell me if you can get the same result. I've been able to reproduce this bug without fail every single time I've tried.

    I hope Ashley finds the source of this problem and fixes it soon. Glitches like these that end up corrupting save data are the some of the worst (if not, the worst) types of bugs imaginable. It's a good thing that I discovered this now beforehand otherwise it would become a much bigger problem later.

  • Yesterday, i had an animation (PNG) that made construct crash when importing it as frames. I cropped the animation 2 pixels, and it got accepted fine. I just tried to reproduce this. But i cant.

    Was pretty annoying though for a while.

    But i cant reproduce your bug too. Add a sprite ? But dont load an image in it ? And then add a animation ? Just scales the animation here to the empty bounding box.

  • So, you can't reproduce it. Damn, I thought I was on to something. Why isn't it doing that for me? I was pretty certain I had found the cause of the one of the many dreaded file corrupting bugs here.

    Well, I guess not. It happens every time I try to do it too (no matter what, image size or whatever). I'm really don't know what to do about it other than not use the import frames feature.

  • For what it's worth, I just reproduced this. Only when using your images, for some reason.

    It seemed to import OK, so I minimized to go post this, then I maximized it and the layout editor won't display.

  • Hmm interesting, got to look again at those images then.

  • blah me missing this earlier. I was caught up in my own import crashes at the moment. Sorry ?

    The aspect ratio of those images is not square. its 1.2 (not 1.1)

    Trying to explain to non graphics people ..

    it means, the image is made out of pixels.

    the pixels this image is made off, are not square.

    Also the dpi is rather rare, namely 104 dpi. This should not matter though.

    Although i think Construct works in 72 dpi ?

    Mach do you still need those ? want me to translate them to square pixels ?

    Oh i just do so u can test them when translated.

    Will be soon known then.

    Up in some minutes.

  • here you go ...

  • I can now say I've experienced this crash as well. I now wish I saved my progress more often. Oh well. Hope it's fixed in the next release.

  • This is fixed in the next build. For reference, it was only a problem with certain types of images. The BMPs linked caused problems, most images don't.

  • I can confirm that this bug has been fixed in the latest Construct version. Thanks! I'm glad I could be of assistance. I'll be sure to report any other bugs I find as I encounter them. Keep up the good work.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)