Construct 0.99.84 released (unstable)

This forum is currently in read-only mode.
  • Sweet, more stability improvements! Now I wonder if that platform behavior modification has made its way in or Deadeye is going to start thrashing about.

    Apparently David's updates have not been included in this build either. I'm still falling through vertically moving platforms. I haven't tested all the other bug that were supposed to have been fixed yet, but that one at least is still there.

    Platform behavior seems to be messed up.

    When (if) David's new fixes are included then this won't be an issue.

  • Okay... according to the bugtesting .cap that I originally sent to David, the fixes that he made are all in 84 (and - embarassingly enough - 83 as well), except that the falling through platforms thing is still there. It doesn't happen all the time in the tester .cap I sent him (it still does occasionally), but it happens a lot more frequently in my Platform School .cap for some reason.

    http://dl.dropbox.com/u/529356/platform ... ground.cap

    So... yeah. I guess I was wrong, and the fixes are there. It's just that the one I checked for in Platform School is still around, but mostly just in Platform School. I don't know what's up, I guess I'll have to do some more testing.

    As for Porlo, try recreating that .62 bug from scratch in .83 or .84 and see if it's still there, I'm not experiencing that bug at all. It could just be a backwards compatibility issue.

  • Try this: http://dl.dropbox.com/u/4322334/test.cap

    The bug has something to do with the objects height.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Confirmed. You should post a bug report

    Also, it goes the other way around too... if you make the sprite 32x31 and resize it to 32x32 then the same thing happens.

  • Hmm, if I open my game in this build the platforming still feels completely different than 99.62.

  • [quote:1l2kuypg]You can change the offset to a negative value.

    Changing to a negative value only make the shadow go up, changing it?s Y.

    I want to flip it vertically, it?s a totally different thing...

  • This release isn't updated with 0.99.82 features, isn't it?

  • [quote:3o6woply]You can change the offset to a negative value.

    Changing to a negative value only make the shadow go up, changing it?s Y.

    I want to flip it vertically, it?s a totally different thing...

    I see, well then I would suggest using a dummy, and setting its dimensions to negative also.

    Less drain on resources than an fx.

  • I just formatted my PC, and I was using 99.83 previously. How's this version, guys? Pretty stable too? Any steps back from the previous version?

  • I just formatted my PC, and I was using 99.83 previously. How's this version, guys? Pretty stable too? Any steps back from the previous version?

    It seems ok, but as always, best to keep the previous version you were using safe, just in case.

  • I just formatted my PC, and I was using 99.83 previously. How's this version, guys? Pretty stable too? Any steps back from the previous version?

    It seems to work fine.

  • I opened my 0.99.62-project in 0.99.84.

    First thing that happened was: all objects with gravity fell through the "Bottom"-sprite.

    (didn't happen in 0.99.62)

    I checked if options (for example "solid" and "immovable") were changed. They weren't.

    I added a 2nd Bottom sprite and suddenly it worked fine.

    Deleted the now obsolete 2nd Bottom sprite and the problem isn't there anymore.

    Just wanted to share this information.

  • There are new physics properties that were added since 0.99.62 that need to populate before physics will work properly. You can do it by just clicking on your physics objects so the Properties tab pops up and fills them in for you. Adding that extra sprite did nothing.

  • yay this version works well when I add sprite and run game

    (it was broken for me after 99.4, either xp sp3 or my card caused it)

  • yay this version works well when I add sprite and run game

    (it was broken for me after 99.4, either xp sp3 or my card caused it)

    That would be because your CPU doesn't support SSE2. 0.99.84 contains the fix that makes it work on such systems

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)