Construct 0.99.5 released (unstable)

This forum is currently in read-only mode.
  • Great update, thanks Devs!

    Still, I think it would be cool to fix that "Cut command working as Copy" bug I reported a while ago: It's too noticeable, I showed Construct to some friends at work at most of them found that extremely annoying.

    I don't know... I already got used to it... But I think this might make some new users lose interest on Construct. And it's also something that wasn't happening on previous versions!

  • Still, I think it would be cool to fix that "Cut command working as Copy" bug I reported a while ago: It's too noticeable, I showed Construct to some friends at work at most of them found that extremely annoying.

    How is it behaving like copy? It seems to be working properly for me.

  • Cut means copy contents to clipboard, and delete the current selection.

    Hence the saying "Cut and paste".

    Well at least it does in most image manipulation programs.....

  • Awesome new release!!! Keep it up devs! Fixed a bunch of bugs, one that I just encountered in .42 then installed .5 and its fixed!

  • is rotate layer, or rotate screen working? It's the first time i'm trying to do it, but can't seem to get either to work. I have 3d layer checked.

    start of layout > set set layer 1 angle to 45

  • is rotate layer, or rotate screen working? It's the first time i'm trying to do it, but can't seem to get either to work. I have 3d layer checked.

    start of layout > set set layer 1 angle to 45

    Try enabling "Unbounding scrolling" in the layout properties. That should work.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • you're right, thanks linkman.

    sorry about the false bug report.

  • I'm having too much trouble with the physics custom collision bug (I went to report it, but I saw it was already there), something that was OK in 98.9. I hope this gets fixed in the next version, as it was one of the coolest features I was using!

  • I tested all recent versions of construct for searching a bug.

    This is quite serious bug so i couldn't continue my project.

    Bug is related with collisions and can crash application very quickly

    It's very easy to notice it because you only need two object with per pixel collison

    to activate it.

    Now i can tell you:

    1. The bug exist only in 2 last versions of construct

    i mean 0.99.42 (Stable build!) and newst 0.99.5

    2.Version 0.99.4 doesn't have problems with it and also runs faster

    than new versions.

    3.Also versions 0.99.0 - 0.93.0 seems working ok.

  • Great pity I can't test it! All builds since 99.3(or .2?) give me the same sprite bug as before. I've submited this bug to the tracker, u devs asked me to put a cap example but this bug doesn't depend on caps but computers - not all computers support last builds, several people met this situation too.

  • i would suggest posting a cap along with some screenshots of what happends to you.. Sounds like a scary bug.

  • Attan, you don't understand. It doesn't depend on cap, it depends on compatibility with other computers. Watch this video - http://ioj.com/v/d5wjg plus screenshots - http://ioj.com/v/gxzk7 and http://ioj.com/v/hp35p - that's when I start debugging (sry for quality but can't do better) . Here I tried to add gradient and it's okay but when I add sprite...well I posted the bug on tracker and here many times, other people posted their caps with the same prob but those caps worked ok for people who's cpu's support latest builds. I also tried some new exe's people posted here on last 3 weeks and also got errors though games like Aquaria, Tagap, Flash Bang Studios games(Paper Moon) or other games that use modern technologies work fine on any computer, even mine. Guys(I mean devs), please solve this problem because if people who's cpu's support latest builds will release games(I mean commercial projects) that most machines will not support , uh...

    In case of smth I'll leave my cpu's specifications:

    AMD Athlon XP 2500+ 1,93 Ghz, GeForce 6600 128 MB, 1GB RAM, Windows XP SP3.

  • Could the bug be something along these lines? This is a serious collision bug I found in 99.42, and it appears to somewhat match your description.

    http://sourceforge.net/tracker/index.php?func=detail&aid=2830539&group_id=207820&atid=1003219

  • Imagine, Davio, I get error when I try to launch the app with sprite! Other plugins work fine. I think there's smth wrong with VC2005...

  • Attan, you don't understand. It doesn't depend on cap, it depends on compatibility with other computers. Watch this video - http://ioj.com/v/d5wjg plus screenshots - http://ioj.com/v/gxzk7 and http://ioj.com/v/hp35p - that's when I start debugging (sry for quality but can't do better) . Here I tried to add gradient and it's okay but when I add sprite...well I posted the bug on tracker and here many times, other people posted their caps with the same prob but those caps worked ok for people who's cpu's support latest builds. I also tried some new exe's people posted here on last 3 weeks and also got errors though games like Aquaria, Tagap, Flash Bang Studios games(Paper Moon) or other games that use modern technologies work fine on any computer, even mine. Guys(I mean devs), please solve this problem because if people who's cpu's support latest builds will release games(I mean commercial projects) that most machines will not support , uh...

    In case of smth I'll leave my cpu's specifications:

    AMD Athlon XP 2500+ 1,93 Ghz, GeForce 6600 128 MB, 1GB RAM, Windows XP SP3.

    xp SP 3 thats what is causing it, I too have that problem and I have been watching other peoples posts with this bug.

    microsoft must have released some update that screws some DX feature, this is not the first time thing like this happened.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)