How can i uninstall the addon if the whole screen is red and blocked?

From the Asset Store
Red Hoodie Boy game sprites for side scrolling action adventure endless runner 2D mobile game.
  • I tried adding a second addon (example) to my construct and now I cant use anything.

    Tagged:

  • I forgot the image

  • The error message tells you what is wrong - the addon ID is misconfigured. Usually you can press F12 and check the browser console for more details.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've run into a case of this error, where fixing the ids isn't making the error go away.

    The error asks you to uninstall the addon, but you cannot do that since all of the UI is blocked as soon as the webapp starts up. Deleting the addon folder from the local web server just replaces the error with a 404. I've tried a bunch of different things, but nothing seems to work. At best, it just results in a different error.

    I guess I could just use a different browser, but is there a way for me to remove construct 3 from the browser and start anew?

    Thanks!

  • Use developer mode. Then you can just fix the problem, reload and carry on.

    If you're not using developer mode, you'll just have to clear the browser data, which will clear the broken addon and all your other browser data. That can be quite inconvenient, which is why developer mode exists.

  • Thanks for responding, and all the work you do!

    I eventually just switched to using another browser, since I did not want to delete all of my other browser data. I also had been doing all of my plugin development using developer mode already, loading in the addon files from the localhost folder on my machine.

    What roughly happened was I started developing with my addon.json id value set to something like "AbC" and then because of some issues switched it to "abc", which triggered this error. Changing it back to "AbC", and reloading afterwards, did not result in this error going away, which just resulted in a dead end.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)