White screen on Android

From the Asset Store
White Island Tileset
$1 USD
75% off
Winter island themed set of tiles for your platformer game
  • I have a strange issue lately. When I start my game on Android I see the game screen showing for a fraction of a second and after the screen turns white. The touch input is working and the the sound is still working. The same build was working flawlessly a couple days ago and I've tried an old game I've made in Construct 2 and it's working fine. I'm using Construct 3 and my test device is an Huawei P20.

  • Please debug your APK.

    Seeing the results in the console will help determine what may be going wrong.

    As it stands, no one can help with your request like that.

  • C2 post 1

    I have been having similar issues on 3 of my apps lately. They were working fine until 2 of them started showing white screen shortly after gameplay starts and one of them shows black screen shortly after the start of the first layout.

    Construct 2 R-252 full release

    Building is done with phonegap-build online

    Initially i thought the problem happened because of appodeal or google play but after removing every plugin, still happens. After few a new export something strange happened. Now the screen turns black instead of white, in the same location in the app.

    Will update on new tests...

    My apps: play.google.com/store/apps/developer

  • So apparently the problem was with samsung ... and i had to disable WebGL and it does not happen any more!

    That might hurt performance on mobile but it seems to be the only choice for me atm.

  • I've tried to debug the app but I got nothing relevant to the issue. I just hope that my phone manufacturer push an update for this issue.

  • I have a strange issue lately. When I start my game on Android I see the game screen showing for a fraction of a second and after the screen turns white. The touch input is working and the the sound is still working. The same build was working flawlessly a couple days ago and I've tried an old game I've made in Construct 2 and it's working fine. I'm using Construct 3 and my test device is an Huawei P20.

    It's the same I got with Phonegap webview build and using Samsung J7 Prime, after disable the webgl mode, it works perfectly, but for some devices doesnt matter, this is very confusing for me whether to using webgl or not :(

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • nevermind, it's already fixed since Construct 2 r265 released.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)