TypeError: e.GetPlugin is not a function ​

0 favourites
  • 6 posts
  • Hi all,

    My project runs ok in preview mode, but when I upload it to my website and try to run it does not work.

    The browser console shows 'TypeError: e.GetPlugin is not a function c3runtime.js:2:511080'

    Same error occurs with Chrome, Firefox and Edge

    Not sure if this is the place to post this kind of error

    Any idea of what is happening, ¿Can you help?

    Thank you,

  • It's difficult to help from just this information. Maybe you have a broken third-party addon. If you think it's an issue with Construct, please file an issue following all the guidelines - note we need all that information to be able to help.

  • Thank you for your answer,

    Right now I was writing to ask you to forget my post...

    As in your "Publishing to the web" recommendations I have activated SSL on my website and everything works fine now.

    Seems that video plugin needs secure connection as I have been able to reproduce a similar error with a simple layer containing only a video plugin.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That still sounds like a bug and I'd still like to fix it if possible.

  • Ok I Will send you all the information asap

  • Hi again,

    I's been a few days since my last post. I have tried today and everything is ok (even with unsecure connection). The error disappeared. I'm confused because I can't imagine the reason why...

    I haven't done any change since my last post.

    Anyway I'll try to test both (secure and insecure conections) every time I upload my project and will tell you if the error appears again.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)