Switching from C2 runtime to C3 (Local Storage bug?)

  • Greetings!

    I've been working with my project on C2 runtime for sometime now and now decided to try out switching to C3 runtime. After switching, my Local Storage saving stopped working. This is for fetching data from local storage and placing it to arrays.

    So basically all stuff which I try to save into arrays, don't work anymore after the switch from C2 to C3 runtime. I did not change any events on anything, just changed the runtime.

    What I've tried so far:

    - Clear storage

    - Creating new arrays with different names (just if C3 runtime arrays would be different)

    - Changing key names on local storage (just to make sure there is no saved data from C2 runtime)

    - Rebooting Construct 3 / Restarting computer

    It seems that the "On Item missing" is not triggering the same way. Local storage does save stuff to arrays, but it just doesn't save the data it was supposed to. (Like it worked on C2 runtime)

    Any thoughts on this? How could I start using C3 runtime without re-creating the whole project?

    Thanks in advance!

    Br,

    Kossad

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I had the same problem . I changed the old local storage for the new local storage and that worked for me . Hoop there is a better way I didn’t find it.

  • Senso Thanks for the answer! So you basically deleted the Local Storage from your project, added it again and created all the events from scratch? Just want to make sure that I understood right. :)

  • Hey!

    So yeah, finally got this working. Before switching to C3 runtime (from C2 runtime) I deleted all the arrays I had and also the LocalStorage plugin.

    After that, I changed to C3 runtime and just for sure, rebooted the engine (open - close). Then, I created the arrays again and also the LocalStorage plugin. Then basically re-created everything (mostly copy paste the events & actions from C2 runtime project) and it seemed like it still does not work.

    After testing out multiple different things, I'm pretty sure the conclusion is that in my C2 runtime project, I used an action "Insert new element" for my arrays. It didn't work the same way on C3 runtime, since it didn't add totally new elements. After switching to C3 runtime, I had to change the action to "Push new element" to get it working.

    After this, it started behaving like it should. So yeah, it seems I'm finally able to continue using C3 runtime!

    Unfortunately, this was not any type of "ultimate fix for the problem". More of a "try out a lot of stuff, lose the sense of time and space and end up having stuff working, without knowing why".

    Just wanted to type it here, if for some reason, someone else finds it useful. Probably not though.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)