How do I select objects?

0 favourites
  • 10 posts
From the Asset Store
A complete set of Graphic, User Interface element to build 2D mobile game or PC game.
  • I feel like a genuine idiot for not being able to figure this out, but it's killing me - and I can't figure out useful terms to Google.

    Anyway, the selection obx for some of my objects is miles away! If I use the scroll bars, I can usually re-centre them, but then it wanders off again. What on earth have I done wrong here!?! So I have to click on the blue box to get the object, but I don't always know where it has wandered off to.

    Thanks in advance!

  • I tried a bunch of ways to replicate that, and couldn't... seem's like a glitch. I would try updating everything - Chrome, C3, video drivers, etc. reboot and try again.

    if that doesn't resolve it, then try making a small version of your file for others to test to see if we get the same results.

  • This looks like your origin/bounding box got messed up. Open your sprite and use the "Edit image point" and "Edit collision polygon" buttons to check/realign your values.

  • Also try clicking on layer and select/deselect "Parallax in editor"

  • Well I tried all of those but no joy. I need to use the scroll bars to recentre the outline over the sprite. It will stay for a while, but then I re-click on the sprite and it has wandered off again!

    Damnedest thing!

    I'm using Brave as a browser, so will give it a run out in Chrome later and see what happens.

    The suggestions wre appreciated tho.

  • So yeah, same thing with Chrome. You can see here how zooming in and out changes the location of the outline.

    Then using the scroll bars also changes it, so even zooming in again may see the position changed.

    Fun right!?

    So this was happening with Chrome and Brave. Any suggestions appreciated.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It could be a driver bug. Either post your project, or copy the object into another new project and try again. You can post that if it still does it so others can try.

  • And if there is anything else that looks wonky - feel free to let me know :)

    Thanks in advance!

  • The z-elevation is set to 1. Put it back to 0. This is definitely related to the layer parallax set to 0x0, and z-elevation set to 1. I have no clue as to how it should behave. Somebody else might know.

  • Ah brilliant, that has fixed all of them!

    Thank you so much for the help - it's really appreciated.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)