The second Gamepad is recognized, but not inputing.

  • I have it set up simply by having player 1 sprite controlled by Gamepad index 0, and player 2 sprite controlled by Gamepad index 1. I also did a console log to see how many gamepads were recognized and it would say 2, if both plugged in, and then 1 if I unplugged one of them.

    So I assumed it should work right out of the box, but it doesn't The browser supports it and recognizes there is another gamepad but nothing happens when I actually press the buttons. I'm sure I'm missing a simple thing.

    Here is a link to the game file.

    https://www.dropbox.com/s/ep7z36oqenotdee/kidsgame.c3p?dl=0[/code:1tmbu9rj]
  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So something weird happened.

    It works now. Not sure why but it does.

    So I decided to do a remote preview and copy the link into a different browser like Mozilla, and now.. it works!?

    In fact, when I came back to using a regular preview it works now on chrome. I'm bewildered.

    Also when I try to see the UserAgent it's picking up as Mozilla 5.0 on chrome. Is that normal?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)