Safari isn't playing sounds, help!

From the Asset Store
75 explosion sound effects. Essential for many games, Explosions Sounds contains a mix of explosion and impact sounds.
  • Greetings,

    I don't own any apple product but I got feedback that sound is not playing on safari . I have also asked for their IOS version and they are all on 12+. Here is project file mediafire.com/file/1buz1usxgt89rbx/Leprechaun_in_Poland.c3p/file, Game is meant to be played via web browser and it works on chrome perfectly. Could some checkout what is going on, I can't test it out when I don't own any apple product.

    Thank you!

    Tagged:

  • Try touching in the game. Maybe after touching, the audio will play.

  • Hello,

    Restart the game and make sure that it has access to your speakers.

  • Hi juxwillx, Thank you for help I have tried both of this and it didn't help.

    Could you Kyatric help me pleas? It really seems like issue is engine related. I have also tried giving fallback files but it still didn't work. I am aware that apple products are causing a lot of problem and by the forums I can see that this is not first time this bug occurred because Safari had weird update or it slacks behind. But I am guessing Construct team wants games to be compatible with Safari and IOS also. So this should be considered as bug?

    Thank you!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Your file makes use of third-part addons, I cannot open it.

    You shouldn't be using Lite Tween as a third part addon anymore when Construct 3 provides a standard behavior (Tween).

    Are you sure you DID respect the autoplay restriction and did make sure that your player HAS to touch the screen BEFORE trying to play any sound ?

    This is not a bug in Construct, it is a requisite from apple products/browsers on mobile, and something you have to strictly follow for your audio engine to initiate as intended (especially on iOS).

  • Hi juxwillx, Thank you for help I have tried both of this and it didn't help.

    Could you Kyatric help me pleas? It really seems like issue is engine related. I have also tried giving fallback files but it still didn't work. I am aware that apple products are causing a lot of problem and by the forums I can see that this is not first time this bug occurred because Safari had weird update or it slacks behind. But I am guessing Construct team wants games to be compatible with Safari and IOS also. So this should be considered as bug?

    Thank you!

    First, make sure you are using the correct sound file type. WebM is the best or FLAC (which will be converted into WebM via C3).

    Second, if the file type isn't the issue, then try moving the sound files from the sound folder into the music folder, or vise versa.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)