How do I run a preview offline?

From the Asset Store
Full game Construct 2 and Construct 3 to post on Google Play
  • It had never occured to me, but when I had issues with my internet the other day, i learnt that I can't run preview on my projects. I'm using the offline version, lates with latest sdk nw.js. I'm certain that I've read that I can use construct offline if needed - just need to log in every now and then.

    What am I missing?

  • I just tried going offline, loading Construct, opening a project and previewing it. It worked fine.

    If it doesn't work please file an issue following the guidelines, but note we'd need reliable steps to reproduce starting from clearing your browser cache, loading C3 online for the first time, then going offline and reproducing the problem (i.e. something we can repeatedly perform to observe the issue multiple times).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Come to think of it, I haven't seen the Ready To Work Offline notification recently. I can't really submit an issue and give you steps to reproduce - because its start offline and that's it. I'm asking if anything comes to mind that may be the issue. For example, I hadn't thought of clearing my browser cache. Did so to no avail. But anything from the sort will be very helpful. This being said I have a bunch of issues that seem unique to me, as we've had back and forths on several of them - the last is that despite having the Stable release setting selected, my offline version updates to the latest beta none the less. Now, because there is no way of you reproducing this, I don't expect an easy solution - but if anything regarding... folder location, admin rights, geographical location and web services, etc...comes to mind, please share. Thanks.

  • My mistake, I get the ready to work offline notification. I installed a fresh copy. cleared all cache from appdata and construct won't load, just some idle processes appear in the task manager.

  • Without steps to reproduce I can only really hazard some guesses - the information we ask for with bug reports is what we need to be able to identify what's really going on. Try pressing F12 and check for errors in the browser console. Maybe there's also some problem with your Internet connection. Perhaps a browser extension is interfering, so try disabling them. Other than that I can't help more without knowing what's really happening.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)