run game on linux?

From the Asset Store
Game "Word Search" with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • How do I run my exported NWJS game on Linux?

    I put my exported Zip onto Linux Mint (I'm new to linux, but this one feels like windows) and when I extracted it, the [project name] file does not have a file extension, so how do I run my game?

    On windows, the file has an .exe which lets you run the game. But why is there no extension at all on the linux version? What am I supposed to do next?

    Thanks!

  • Executables on Linux are specified by an executable file permission rather than using any specific file extension.

    You can run it from the terminal. IIRC Linux supports desktop shortcuts but last I checked these only work with absolute paths, so Construct can't auto-generate that as it doesn't know where in storage the files will be extracted. I think you'd have to make an installer or something to put the right desktop files in. It might have also varied depending on the distribution or window manager. I think it was kind of a mess last I looked in to it...

  • Thanks Ashley!

    I'm not sure how to run it from terminal. (Also just as a heads up your tutorial doesn't say how to do run the game either construct.net/en/tutorials/exporting-desktop-apps-nw-js-15) Maybe Linux is just not supposed to be user friendly.

    But yeah it seems really messy, or tedious, attempting to make builds for non-Windows systems unfortunately. Perhaps it's just not really possible.

  • 1. Open a file browser and search where extract the project

    2. Right click > open in terminal

    3. type: ./'New project'

    (New project the default name. Your project will be different)

    In linux the start file will be the project name (default: New project) without extension

  • Thanks nyuszi008, my game is running using that!

    I'm guessing that when it's on Steam, that Steam will somehow just run the file without having to type a command in terminal each time.

    Interestingly, I transferred both the zip and the extracted zip to the Linux Mint computer, and it seems to be able to run both versions.

    However the external level data files that I normally include alongside the .exe on Windows, when I transfer them from windows to linux it doesn't seem like that works here. Perhaps it's related to that permissions thing.

  • I put my game on steam. (i haven't released my game yet, I put it for testing) ran smoothly without any adjustments

  • Eren that's great did you also do a Mac build?

    also do you have links to the game you are working on?

  • yes, I also did a mac build and tested it on steam

    it works

    unfortunately don't have links. I will share the link when I activate my steam page.

  • nyuszi008Ashley (or anyone else)

    I tried opening my game using terminal but it doesn't run.

    Do you know what what I could do, or what this terminal message means?

    Thanks for the help!

  • You might have a problem with permissions. Extract the zip and run the game with the same user. But the message says that the file cannot exist. (might missing something in the extract folder)

  • I remember before, for permissions, you could drag the file into a browser (chrome) and then release it to be downloaded by the browser, and after that, open the file, this way the permissions problem would be solved ...

    Of course, I tried this solution years ago

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Thanks for the help.

    I didn't encounter this issue a few months ago (as seen above).

    Instead of transferring the export from my Windows computer, I tried exporting the NWJS directly through Firefox on Linux.

    But I get the same result no matter what I do. Even this issue:

    When I tried opening the "Lib" folder, it requires me to authenticate:

    Could it just be an issue on NWJS end then?

    Has anyone else tried exporting their game and running on linux recently?

    Thank you!

  • Some case a 'lib' folder need admin rights (e.g. lubuntu)

    Try run: sudo ./'Your game'

    Now work for me. (just nw.js sdk) It might be a bug in construct.

    If command drop errors might be a display driver bug. I have to install the original nvidia driver in ubuntu (I have a laptop)

    Bug report: github.com/Scirra/Construct-3-bugs/issues/5017

  • It appears to just be a problem with the latest 55 NWJS, because I exported with 54 and it works!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)