Problem with touch and buttons in Safari [Solved!]

  • Hi all,

    I have a game based on the "Physics Catapult" template, built using R131: it's a basic angry birds clone.

    I've exported to HTML5: on Windows/Chrome and Android it works as expected, but not ipad Safari.

    The initial layout features a text entry box and a button object which, when clicked, should load level 1 layout. (Naturally, the project uses the Touch Object.)

    Problem is that the button doesn't work. I've tried changing it to a sprite object "button" to call the same events, but that doesn't work either.

    Problem occurs both if I access the game directly or via an iFrame.

    I know IOS has trouble with music, so I've tried deleting it from the initial loading screen, but no joy.

    Does anyone know why this might happen?

    Thanks very much,

    Matt

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Are you saying you've tried with a sprite button and "On touched MySprite" event?

    It's possible that the TextBox is somehow retaining the focus and intercepting all touch events. Try removing the TextBox. If it helps, then you can make your own version of text box, see this tutorial:

    scirra.com/tutorials/739/your-own-textbox

  • Hi and thank you very much for your suggestion! I tried it out, but no luck I'm afraid. :(

    Anyway, yes - you understood completely: I had the sprite button set to fire with the On tap gesture on sprite event, but now I changed it to on touch and removed the text entry box completely - same result as before: game loads, but sprite and buttons both remain inoperative.

    But wait... it gets worse...

    I tried taking out the initial layout, so it would load directly into the gameplay on the "second" layout: the loading screen appears, but instead of my Level 1, all that loads is a black/blank screen.

    I'll update iOS in the meantime (it can't hurt) but I'm still very much stuck.

    Any ideas?

    Thanks again.

    Matt

  • Ahhh, OK. Resolved it.

    I tested on a slightly-more-up-to-date iPad and it worked just fine.

    Thanks for the help anyway - I appreciated the effort.

    Best,

    Matt

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)