I Need Help with Webview+ BLACK SCREEN Jan 2018 Problem!

  • Hi all! Can someone please help me with this new black screen of death problem? I use the same framework for all my apps, month after month (all I do is reskin), and everything always works fine - I’ve never seen this black screen before. I’ve never changed the make, export or build configuration of the app, so I have absolutely no clue where this problem came from. Can someone please help?

    Cocoon Version:

    Latest

    Basic description of the problem:

    Cocoon build works fine, but when I try to open the apk on my Samsung phone, I get nothing but a black screen. My other app worked just last week, and I’ve changed absolutely nothing in this project regarding the build export and build configuration.

    Device info:

    Android 4.4.2

    Steps will reproduce the problem:

    1. Export on Construct 2 with these options in place…

    Fullscreen in browser: Scale inner

    Fullscreen scaling: High Quality

    Use High-DPI display: Yes

    First Layout: Preload

    Use Loader Layout: Yes

    Physics: Box2D asm.js

    Loader Style: Nothing (not recommended)

    Enable WebGL: On

    2. Export with Minify script unchecked.

    3. Delete all xml files, and zip to

    4. Upload www zip file to Cocoon with these options in place…

    Cocoon Version: Latest

    Webview engine: Webview+

    minSDKVersion: 16

    targetSDKVersion: default

    Install Location: Internal Only

    Multidex enabled: No

    Expected result:

    To build as usual and see the app work, as it did in the past.

    Error log

    There was no log error, because the build works fine. The build’s not the problem. I’m getting the black screen of death afterwards.

    Used plugins (if relevant):

    Recently I installed a new effect in Construct 2. It was called “outline”. Is it possible that the effect is causing the problem?

    Framework/game engine (if relevant):

    Construct 2

  • This is what my config.xml looks like now....

    <?xml version="1.0" encoding="utf-8"?>

    <widget xmlns="http://www.w3.org/ns/widgets" xmlns:cocoon="http://cocoon.io/ns/1.0" xmlns:cdv="http://cordova.apache.org/ns/1.0" id="com.dailyoccultcorrespondences.magicmotherboard" version="1.0.0">

    <name>Occult Correspondences</name>

    <description>

    A sample Cocoon application that responds to the deviceready event.

    </description>

    <author email="sbstn@live.ca" href="https://cocoon.io">

    Magick Motherboard Productions

    </author>

    <content src="index.html"/>

    <plugin name="cordova-plugin-whitelist" version="1"/>

    <access origin="*"/>

    <allow-intent href="http://*/*"/>

    <allow-intent href="https://*/*"/>

    <allow-intent href="tel:*"/>

    <allow-intent href="sms:*"/>

    <allow-intent href="mailto:*"/>

    <allow-intent href="geo:*"/>

    <platform name="android">

    <allow-intent href="market:*"/>

    <preference name="enabled" value="true"/>

    </platform>

    <platform name="ios">

    <allow-intent href="itms:*"/>

    <allow-intent href="itms-apps:*"/>

    </platform>

    <preference name="Orientation" value="landscape"/>

    <preference name="Fullscreen" value="true"/>

    <preference name="android-minSdkVersion" value="16"/>

    <plugin name="com.ludei.webviewplus.ios" spec="*"/>

    <plugin name="com.ludei.webviewplus.android" spec="*"/>

    </widget>

  • Bump.

  • Has no one else been having black screen issues with Cocoon's Webview+?

  • Please, I really need someone's help.... Anyone out there?

  • By far the most useful thing to do to identify the problem is set up USB debugging with the device, attach an inspector via chrome://inspect, and see if any error messages appear in the console. Otherwise you'll be on a wild goose chase.

  • USB debugging?... I don't know how to do that... This makes no sense the problem came out of nowhere. I'm thinking it's a problem on Cocoons side. I'm trying to see if anyone else is having this same issue. Ashley, you haven't heard of anyone else having this Webview+ black screen problem?

  • Nope. Maybe you could contact Cocoon's support about it, or try a different build service like PhoneGap Build.

  • Ashley could it be a Construct 2 effect I'm using that's the problem? For this app, I happened to include a new effect I've never used before in any other project before. The effect was called 'outline'. Could it be that the new effect I'm using is causing the app to not work correctly?

    [I actually don't think it's Cocoon. I just tried Webview+ with another app and it worked fine, so I'm guessing it's the new effect I'm using.]

  • Could someone please help me out, by installing/including the same effect plugin ('Outline') in a Construct 2 project, then seeing what happens when you build with Cocoon's Webview+? If you get the black screen as well, I'll know it's the effect, and I'll stop using it.

    Here's the link to R0J0hound 's 'Outline' effect plugin....

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • You can test if it's the cause by deleting it from your project and then seeing if it works again. In fact that's a good way to isolate what's wrong - if a new empty project works, make a backup and delete your way back to there, and see when it starts working again.

  • It was. Thanks.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)