Need help with C3 IAP Plugin

  • Hi,

    I have setup IAPs and enabled them on the Play Console but shows the below error.

    These are my events.

    Can anyone help me understand where it went wrong?

    Let me know if you need further info.

    Thanks in advance.

  • You're missing some information in your store list on the Google Developer Console, either it is IAP Product Listings, Merchant Account, Activation of Products, Game Publishing (Game is not published, at least internal testing), Public Key wrong input on the IAP Plugin and etc.

  • I have checked, all of them are good. I'm not sure where it went wrong.

    Are my events correctly setup?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Can anyone help me understand where it went wrong?

    Let me know if you need further info.

    Thanks in advance.

    You call the restore every tick with your code here. But that's not the root of your problem.

    In order to test IAP, you must upload your apk first to Google Play and download it via the store.

    If you just copy your exported apk to your device, it will not work.

    At least, this is how I can remember it.

    Best,

    Andy

  • Hi corporatedrone! :)

    By here:

    1. Sign in to your Play Console.
    2. Click All Applications.
    3. Select an app.
    4. Select Development tools > Services and APIs.
    5. Find the section labeled, "Your license key for this application."

    Source: support.google.com/googleplay/android-developer/answer/186113

  • >

    >

    > Can anyone help me understand where it went wrong?

    >

    > Let me know if you need further info.

    >

    > Thanks in advance.

    You call the restore every tick with your code here. But that's not the root of your problem.

    In order to test IAP, you must upload your apk first to Google Play and download it via the store.

    If you just copy your exported apk to your device, it will not work.

    At least, this is how I can remember it.

    Best,

    Andy

    Yes, you are right but I already uploaded new version into beta release still shows the same. :/

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)