Mobile Advert: How to configure?

  • Greetings!

    I've been trying to get the Mobile Advert working on my project. I've done this multiple times on different projects, but this time for some reason, I can not get the ads running.

    I've tried debugging it for some time and it seems like the whole Mobile Advert does not configure successfully.

    So when I try to check "is Configured" for Mobile Advert, it never triggers.

    I've checked the IDs multiple times that everything should be correct. So I've added the following ID's to the project:

    - Android Application ID

    - Publisher ID

    - Privacy Policy URL

    So when trying to set an event "is Configured" and hide an object when that happens, it never triggers. So it seems that the Mobile Advert is not configured? I guess it is supposed to be in order to get it working?

    And yes, I've built signed APKs to google play and it does not help.

    Any suggestions from anyone what should I still try to get it working? I'm pretty much out of ideas and thats why I'm here asking for help.

    Thanks for everyone in advance!

    Br,

    Kossad

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Greetings Javanie!

    Thanks for pointing that out, I have though followed this tutorial like a bible. Unfortunately without success.

  • Hey Kossad, have you tried checking the error message expression? It should return a string containing the reason for the configuration failure in the "on configuration failed" condition.

  • Hey Nepeo!

    I did not try it until you mentioned it, but it seems like the error message expression doesn't contain anything. Just empty string.

    I would just like to make sure Nepeo I've done stuff correctly.

    - I followed that tutorial which was mentioned above to get the proper ID's

    - I exported signed APK build to Google Play

    - Made an internal release of the game

    - Installed game

    And I have no proof that the configuration is responding in any way. Like, nothing. I have a feeling that I'm making something very "basic" wrong here, but can't just figure it out.

    Thanks in advance!

    Br,

    Kossad

  • Hey!

    Just made brand new accounts, new game and tried stuff out from the scratch and still no success. Can someone please confirm that the Mobile Advert plugin is actually working?

    Thanks!

  • It can be quite a pain to get it working, despite my best efforts to make it easy. The underlying mobile APIs are just awkward unfortunately.

    You are welcome to submit your project to either our issue tracker or to me personally at iainxej@scirra.com and I will look into the problem for you.

  • Thank you very much Nepeo for offering assistance! I just sent you an email.

    Br,

    Kossad

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)