Making full screen initiate on mobile

  • Noticed that even with the Fullscreen selected for mobile games, the game launches with a black thick border all around the window. I have to slide up the Game Tools option on the bottom of the screen to enable full screen on the game. Anyone know how to make it fully full screen by default for all users?

    https://www.dropbox.com/s/53tt8ogunt54p11/Screenshot_20180702-202531_Soccer%20Dribble%20Flick.jpg?dl=0

  • Noticed that even with the Fullscreen selected for mobile games, the game launches with a black thick border all around the window. I have to slide up the Game Tools option on the bottom of the screen to enable full screen on the game. Anyone know how to make it fully full screen by default for all users?

    https://www.dropbox.com/s/53tt8ogunt54p11/Screenshot_20180702-202531_Soccer%20Dribble%20Flick.jpg?dl=0

    In my project I use layouts with the size 1440 x 1920 Then I set Viewport size to 1080 x 1920, Viewport fit is set to Cover and Fullscreen mode is set to Scale outer. I have an invisible sprite in the exact middle of the layout with the "Scroll to" on it.

  • That doesn't seem to work for me. I still get black bars on the top and bottom, but it resolved the bars on the sides. Are you doing anything else that prevents the black bars? Perhaps Browser > Fullscreen? Thanks for the help!

  • Browser > Fullscreen should indeed help out, if you are executing in a browser.

    It should be called on a user input and likely will not work at all on iOS.

    If you are exporting as Cordova/building an APK, supporting multiple screen sizes should apply.

    It possibly is a matter of finding out the correct setup between your project's size, resolution and the correct full screen option to use.

  • Is there any solution to work around not being able to full-screen my game on ios ?

  • Is there any solution to work around not being able to full-screen my game on ios ?

    When you export as Cordova/xCode, using the correct resolution/letterbox scaling (or the fullscreen property that fits best) works as intended.

    At worst, you can mess around in the export/code to make it a full screen application.

    When executing as a web hosted project in a safari browser, I'm not sure though.

  • Kyatric Thanks, but I've been through the tutorial on a few occasions and have launched mobile games successfully with no issues. It's just that in Construct 3 I can't seem to get it to look right. Just wondering if any has successfully launched games with Construct 3 (Android or iOS) with no black bars and correct scaling. Thanks!

  • I did when using said properties and exporting as an APK out of Construct.

  • Kyatric do you have an example cp3 file? I followed the steps and still running into issues. Thanks!

  • Actually figured it out. Thanks!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Actually figured it out. Thanks!

    How did u figured it out Can u please help us.

    Problem :- I am making a Android and IOS Platformer game in landscape mode and i have a problem with the resolutions.

    My initial resolution (Viewport size) is 854 x 480 (i.e the Aspect ratio is 16:9). and the layout size is (25,000 X 480, 27500 X 480 and so on..)

    I tried many different ways of fullscreen mode and etc. and none seems to work perfectly for all devices.

    Please help me to make my project work on all multiple screen size devices (i.e. IphoneX, Ipad, Iphone 5s, Iphone 6, Iphone 6Plus, & all IOS devices & All Size Android Devices).

  • Not completely solved on my end. Noticed these steps only work for certain instances. I have a couple other games where the same setup does not produce fullscreen. The best I can do is black bars on top and bottom.

  • this issue seems to happen on some devices as my "samsung galaxy j7" has similar issue, but on my friend's "redmi note 4" phone it scales properly, so to fix this I just press the multitasking window button then get back to the game which fixes the scaling issue. I have my scaling set to "scale inner", layout and viewport size set to "1080 x 1920".

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)