loadingprogress does not work as before

1 favourites
  • 7 posts
  • Everything worked fine in Construct 2. Sprite Fonts and Tilemap are responsible for my loading. For both, it was written:

    For Sprite Fonts: round (loadingprogress * 100) & "%"

    For Tilemap: round (loadingprogress * 1080)

    Now, instead of an interesting download, nothing happens, but immediately 100% and ready. And that's not because Construct 3 is fast. He's not fast. My project from Construct 2, after assembly, became even more dull than before. Although I studied and configured all the possible settings. Help! I didn't find anything on the Internet except what worked fine in Construct 2 before. But when I switch to the Construct 2 engine in Construct 3 itself, everything works correctly.

    В Construct 2 все работало без проблем. У меня за загрузку отвечает Sprite Fonts и Tilemap. Для обоих было прописано:

    Для Sprite Fonts: round(loadingprogress*100)&"%"

    Для Tilemap: round(loadingprogress*1080)

    Теперь вместо интересной загрузки ничего не происходит, а сразу 100% и готово. И это не из-за того, что Construct 3 быстрый. Он не быстрый. Мой проект из Construct 2, после сборки стал тупить еще больше, чем раньше. Хотя все возможные настройки изучил и настроил. Помогите! В интернете не нашел ничего, кроме того, что раньше работало нормально в Construct 2. Но когда переключаю на движок Construct 2 в самом Construct 3, всё работает правильно.

    Tagged:

  • This is English forum, you need to post in English. Here is the Russian Construct community forum:

    c2community.ru/forum

    .

    Are you testing in preview? Maybe you need to export to HTML5 for loadingprogress to work properly. If you are sure it works in runtime 2 and doesn't work in runtime 3, you should log a bug report:

    github.com/Scirra/Construct-3-bugs/issues

  • Thank you, I understand) Regarding confidence ... yes, I'm sure. There is an F4 button for this. She will always show you how the entire application works. On account of gidhub, I don’t know how they do it and where to get the report?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • F4 runs the project in preview mode. You need to actually export the game to test. And if loadingprogress doesn't work in exported game, then log a bug report on github.

  • F4 shows everything as it is. I did the assembly through cordova on android and more than once.

  • loadingprogress possibly doesn't work in Cordova export, only in Web (HTML5).

  • Definitely something with the c3 engine interpreter. C2 has no problem. I also tried to build with c3 tools. Thanks for the tip about git hub.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)