Layer "use own texture" question

0 favourites
  • 8 posts
  • I have two layouts, each with three layers. Two of the layers on each, both with minimal assets on them, have “use own texture” flagged to yes. According to the manual, that’s just a read-only display to inform me whether they’re using their own texture. I have no idea why they’re doing it, though.

    I don’t have “force own textures” set. Neither layer has any effects applied to it. They’re at full opacity, and they use the normal blend mode. Those are the most common causes I read about that can compel a layer to use its own texture, and I can confirm that they don’t apply here.

    I’ve read that layers using their own texture adds some performance overhead, which is something I’m trying to minimize. I can combine all three layers into one if I have to, but I was curious if anyone knew why they might be flagging that way.


  • Do you mean "Force own texture" flag is set in the layout editor? Or is it in runtime, when you are running your game in debug mode?

    If in the editor, simply disable this flag, it's not read-only.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If you load up a layer in Construct 3, the Properties panel gives you a number of options in each category. Under "Appearance," there is: a "Transparent" check box, the "Background Color" selector, the Opacity selector, the "Force Own Texture" checkbox, and a readout labeled "Uses Own texture," set to either yes or no.

    On my trouble layers, "Force Own Texture" is unchecked, and Opacity is at 100%, but "Uses Own Texture" is set to "yes" without any way to modify it. According to the Construct 3 manual page for layers, Uses Own Texture is "a read-only property indicating if the layer renders to an intermediate texture. This has a performance overhead. The Force Own Texture setting enables this, but some other properties also cause the layer to use its own texture...."

    It goes on to explain what other settings can cause a layer to use its own texture even when not forced to. My problem is that none of those settings are active on my trouble layers, which is why I'm so confused as to what is causing them to do so anyway.

  • Sorry, I see it now. Have you tried creating a new layer and moving all objects from the problem layer one by one onto it?

    You should be able to see what causes this property to switch to "yes".

  • That's a good idea. Worst case, I think I can consolidate everything onto a single layer without it affecting the game, but I am curious to know what the troublemaker is.

  • The manual lists every possible reason IIRC. If you can't figure out what causes it, share a minimal project demonstrating the issue and I'll take a look.

  • Thanks for the offer, Ashley. I think I figured it out. The other day, I flagged the "Show Translucent Inactive Layers" option on the Layer property bar, just to make it easier to offset the layer I'm currently working on. That appears to be the issue. When I activate it, all of my layers switch to "Uses Own Texture = yes." As soon as I turn it off, they revert to "Uses Own Texture = no."

    I am actually a little bit disappointed. I thought I had stumbled across an area I could tweak for performance gains.

  • Ah, that sounds like a bug. I filed this to follow up:

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)