How do I keep the pixels in the game solid?

  • Hi everyone. I joined a year ago but I started using seriously Construct 3 a couple of days ago, and I'm experimenting and doing stuff... It's really great.

    Anyway, I'm here to ask some questions related on my pixel art.

    I'm not good at words, so I'll just use some pictures that should help me out.

    This is a project of mine I'm making on Construct 3. In this screenshot I just opened the game. Everything looks as intended. But, if I move my character, either the background or the character himself starts to blur.

    I come from Game Maker Studio 2. I'm not good at programming, so I switched to Construct 3, but I've never seen this issue before.

    Is there a way to fix this?

    Secondly, I added in the game a zoom-in camera feature that is just intended to be used for personal purposes, altough it's important. Anyway when I zoom in this is the result:

    Everything is pretty much blurred. I don't know why. The sprites are in gif.

    Doesn't Construct 3 scale the pixel?

    Is there any way to find a solution?

    Thank you for reading, wish you to have a good day.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • When you create a project, make sure you tick "Optimize for pixel art". If you've already created the project, apply the same settings as described in the manual.

  • When you create a project, make sure you tick "Optimize for pixel art". If you've already created the project, apply the same settings as described in the manual.

    Thank you so much for your response!

    Yes it is true I've not enabled the "optimize for pixel" option.

    So I went to my project and selected "proprieties" then enabled in "sampling" the option "to the closest". This definitely solved my problem, and I hope this will help someone else, too.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)