iOS publishing help

0 favourites
  • 5 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • Hi guys,

    Thought I'd get my games onto iOS and oh my how it's a pain compared to android. So, I don't own an iOS device of any time so I've bought a virtual machine, full root access etc.

    After an agonising few hours of head scratching regarding certificates, finally managed to self sign as I couldn't get the auto sign to work. Obviously as I'm using a VM I can't use the simulator properly as it's really laggy but got a couple of friends with iOS so invited them to TestFlight and had one of them round so I could test physically.

    So initial observations: the app would load, start, IDFA would prompt and consent given. Started to play and the app would restart back to the loading screen, did this a couple of times but finally was playable. Then the ads were not displaying and IAP price not reflecting.

    I noticed in xcode that the metadata was missing for the IAP, on Android, as long as the product ID's are the same then the app pulls the data from the play store listing, is this not the same for iOS?

    And with the ads, they're all configured correctly, work fine on Android (and yes, I changed advert IDs), is there any additional configuration needed in xcode to get these running?

    I believe xcode had 42 yellow depreciation flags so maybe a few of these dependencies need updating? The big worry is the constant rebooting - tested on a 2020 SE and a iPhone 12 Pro, so memory shouldn't be an issue

  • Removed ads and IAP earlier to see if this was causing the issue but sadly not. Random reboots to splash screen anywhere between 10-30 seconds into the game.

    Ashley any known issues with R270 and iOS? Can't really submit a bug report as I can't provide any reports etc, TestFlight is showing 0 crashes.

    I'll try my other game tomorrow and see if that one works.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • 3rd update: Tried another game and it worked! Noticed the file mode for the first game was on legacy not app, this could be the issue, but rebuilt the first game in R268 on app and it works!

    Will test R270 on Monday with the same config and see if its all still working

    Edit: working on the 2020 SE but the 12 pro still nada

  • Just pulled this from the laggy simulator as it crashed (doesn't restart to loading splash screen on the sim, stops dead)

    Having found a few other threads with similar errors im guessing some audio files are at fault

  • Small update: There was an old rogue .MP3 file and a couple of .ogg audio files, removed .MP3 and changed the .ogg to .webm.

    Still crashing! Tried adding the font to the .plist file to see if the font was to blame, found a topic on stackoverflow that suggested the FontServicesDaemonManager was caused by a memory leak due to auto layout size (on a native app) so tried tinkering with request full screen etc but to no avail. Seems to crash when going onto level 1, a cutscene happens and crashes then. The rest of the cutscene will play (images fade etc) but when the black fade sprite I use appears to transition from the cutscene to the main level, fade in happens, new black sprite appears but fails to fade out

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)